junior19

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Jessica's Reading Problem
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11567   Accepted: 3925

Description

Jessica's a very lovely girl wooed by lots of boys. Recently she has a problem. The final exam is coming, yet she has spent little time on it. If she wants to pass it, she has to master all ideas included in a very thick text book. The author of that text book, like other authors, is extremely fussy about the ideas, thus some ideas are covered more than once. Jessica think if she managed to read each idea at least once, she can pass the exam. She decides to read only one contiguous part of the book which contains all ideas covered by the entire book. And of course, the sub-book should be as thin as possible.

A very hard-working boy had manually indexed for her each page of Jessica's text-book with what idea each page is about and thus made a big progress for his courtship. Here you come in to save your skin: given the index, help Jessica decide which contiguous part she should read. For convenience, each idea has been coded with an ID, which is a non-negative integer.

Input

The first line of input is an integer P (1 ≤ P ≤ 1000000), which is the number of pages of Jessica's text-book. The second line contains P non-negative integers describing what idea each page is about. The first integer is what the first page is about, the second integer is what the second page is about, and so on. You may assume all integers that appear can fit well in the signed 32-bit integer type.

Output

Output one line: the number of pages of the shortest contiguous part of the book which contains all ideals covered in the book.

Sample Input

5
1 8 8 8 1

Sample Output

2

Source

题意:书本有p页,p[i]指第i页的知识点种类,求涵盖所有知识点种类的最小连续区间。
# include <cstdio>
# include <set>
# include <map>
# include <algorithm>
using namespace std;

int a[1000001], p;
void solve(int n)
{
    int ans = p, l=0, r=0, num=0;
    map<int, int>m;
    while(1)
    {
        while(r<p && num<n)
        {
            if(!m[a[r]])
                ++num;//记录新知识个数
            ++m[a[r]];
            ++r;
        }
        if(num < n)
            break;
        ans = min(ans, r-l);
        if(--m[a[l]] == 0)
            --num;
        ++l;
    }
    printf("%d\n",ans);
}
int main()
{

    while(~scanf("%d",&p))
    {
        set<int>s;
        for(int i=0; i<p;++i)
        {
            scanf("%d",&a[i]);
            s.insert(a[i]);
        }
        int n = s.size();//记录知识种类数
        if(n==1)
        {
            puts("1");
            continue;
        }
        solve(n);
    }
    return 0;
}



posted on 2017-02-28 23:05  junior19  阅读(108)  评论(0编辑  收藏  举报