junior19

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

reference:http://blog.csdn.net/zwj1452267376/article/details/50660202

Bound Found
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 3401   Accepted: 1049   Special Judge

Description

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: "But I want to use feet, not meters!"). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We'll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t. 

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.

Input

The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.

Output

For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.

Sample Input

5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0

Sample Output

5 4 4
5 2 8
9 1 1
15 1 15
15 1 15

Source

题意:找出一段连续区间,他们的和的绝对值与t最接近。

思路:计算前缀和后,小到大排序,这样就可以保证计算每段区间和时是正数,然后尺取。

# include <iostream>
# include <cstring>
# include <cstdio>
# include <cmath>
# include <algorithm>
# define MAXN 100000
# define INF 0x3f3f3f3f
using namespace std;
struct node
{
    int x, id;
}a[MAXN+3];

bool cmp(node a, node b)
{
    return a.x < b.x;
}

int main()
{
    int n, k, t, l, r, ans, tmp, al, ar;
    while(~scanf("%d%d",&n,&k),n+k)
    {
        a[0].x = a[0].id = 0;
        for(int i=1; i<=n; ++i)
        {
            a[i].id = i;
            scanf("%d",&a[i].x);
            a[i].x += a[i-1].x;
        }
        sort(a, a+n+1, cmp);
        while(k--)
        {
            scanf("%d",&t);
            int l=0, r=1, ans, eps = INF;
            while(r <= n)
            {
                tmp = a[r].x - a[l].x;
                if(abs(t - tmp) < eps)
                {
                    eps = abs(t - tmp);
                    ans = tmp;
                    al = min(a[l].id, a[r].id) + 1;
                    ar = max(a[l].id, a[r].id);
                }
                if(tmp > t)
                    ++l;
                else if(tmp < t)
                    ++r;
                else
                    break;
                if(r==l)
                    ++r;
            }
            printf("%d %d %d\n",ans, al, ar);
        }
    }
    return 0;
}



posted on 2017-03-02 23:38  junior19  阅读(111)  评论(0编辑  收藏  举报