junior19

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

AGTC
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12744   Accepted: 4801

Description

Let x and y be two strings over some finite alphabet A. We would like to transform x into y allowing only operations given below:

  • Deletion: a letter in x is missing in y at a corresponding position.
  • Insertion: a letter in y is missing in x at a corresponding position.
  • Change: letters at corresponding positions are distinct

Certainly, we would like to minimize the number of all possible operations.

Illustration

A G T A A G T * A G G C

| | |       |   |   | |

A G T * C * T G A C G C

Deletion: * in the bottom line
Insertion: * in the top line
Change: when the letters at the top and bottom are distinct

This tells us that to transform x = AGTCTGACGC into y = AGTAAGTAGGC we would be required to perform 5 operations (2 changes, 2 deletions and 1 insertion). If we want to minimize the number operations, we should do it like

A  G  T  A  A  G  T  A  G  G  C

|  |  |        |     |     |  |

A  G  T  C  T  G  *  A  C  G  C

and 4 moves would be required (3 changes and 1 deletion).

In this problem we would always consider strings x and y to be fixed, such that the number of letters in x is m and the number of letters in y is n where n ≥ m.

Assign 1 as the cost of an operation performed. Otherwise, assign 0 if there is no operation performed.

Write a program that would minimize the number of possible operations to transform any string x into a string y.

Input

The input consists of the strings x and y prefixed by their respective lengths, which are within 1000.

Output

An integer representing the minimum number of possible operations to transform any string x into a string y.

Sample Input

10 AGTCTGACGC
11 AGTAAGTAGGC

Sample Output

4

Source

题意:给两个字符串,计算由第一个变成第二个的最小操作次数,只可以删除,添加和转换操作。

思路:略。

# include <iostream>
# include <cstdio>
# include <cstring>
# include <algorithm>
# define MAXN 1000
using namespace std;
char a[MAXN+3], b[MAXN+3];
int dp[MAXN+3][MAXN+3];
int main()
{
    int n, m;
    while(~scanf("%d%s%d%s",&n,a+1, &m, b+1))
    {
        memset(dp, 0, sizeof(dp));
        for(int i=1; i<=m; ++i)
            dp[0][i] = i;
        for(int i=1; i<=n; ++i)
            dp[i][0] = i;
        for(int i=1; i<=n; ++i)
            for(int j=1; j<=m; ++j)
            {
                dp[i][j] = dp[i-1][j-1] + (a[i]!=b[j]);//转换
                dp[i][j] = min(min(dp[i][j], dp[i-1][j]+1), dp[i][j-1]+1);//删除和增加
            }
        printf("%d\n",dp[n][m]);
    }
    return 0;
}



posted on 2017-03-04 14:40  junior19  阅读(196)  评论(0编辑  收藏  举报