junior19

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Palindrome
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 62132   Accepted: 21652

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

Source

题意:给一个字符串,求最少添加几个字符使其变成回文串。

思路:将字符串倒置形成新的字符串,求两者的最长公共子序列ans,字符串长度-ans即为答案。

# include <iostream>
# include <cstdio>
# include <cstring>
# include <algorithm>
# define MAXN 5000
using namespace std;
int main()
{
    int dp[2][MAXN+1], len;//dp数组压缩内存。
    char a[MAXN+3], b[MAXN+3];
    while(~scanf("%d",&len))
    {
        scanf("%s",a+1);
        memset(dp, 0, sizeof(dp));
        for(int i=1; i<=len; ++i)
            b[i] = a[len-i+1];
        int t=1;
        for(int i=1; i<=len; ++i)
        {
            t = 1-t;
            for(int j=1; j<=len; ++j)
            {
                if(a[i]==b[j])
                    dp[t][j] = dp[1-t][j-1] + 1;
                else
                    dp[t][j] = max(dp[t][j-1], dp[1-t][j]);
            }
        }
        printf("%d\n",len-dp[t][len]);
    }
    return 0;
}



posted on 2017-03-04 15:19  junior19  阅读(174)  评论(0编辑  收藏  举报