junior19

  博客园 :: 首页 :: 博问 :: 闪存 :: 新随笔 :: 联系 :: 订阅 订阅 :: 管理 ::

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19405    Accepted Submission(s): 11684


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
16
 

Author
CHEN, Gaoli
 

Source
题意:求一个数组所有循环同构体中,逆序数最小的值。

思路:先用线段树求出原始序列的逆序数,后面的就可以推导出来了。

# include <iostream>
# include <cstdio>
# include <cstring>
# include <algorithm>
# define MAXN 5000
# define lson l, m, id<<1
# define rson m+1, r, id<<1|1
using namespace std;
int sum[MAXN<<2], a[MAXN+1];

void init(int l, int r, int id)
{
    if(l == r)
        return;
    int m = (l+r)>>1;
    init(lson);
    init(rson);
}

void update(int p, int l, int r, int id)
{
    if(l == r)
    {
        ++sum[id];
        return;
    }
    int m = (l+r)>>1;
    if(p <= m)
        update(p, lson);
    else
        update(p, rson);
    sum[id] = sum[id<<1] + sum[id<<1|1];
}

int query(int L, int R, int l, int r, int id)
{
    if(L <= l && R >= r)
        return sum[id];
    int m = (l+r)>>1;
    int ans = 0;
    if(L <= m)
        ans += query(L, R, lson);
    if(R > m)
        ans += query(L, R, rson);
    return ans;
}

int main()
{
    int n, total;
    while(~scanf("%d",&n))
    {
        total = 0;
        memset(sum, 0, sizeof(sum));
        init(0, n-1, 1);
        for(int i=0; i<n; ++i)
        {
            scanf("%d",&a[i]);
            total += query(a[i], n-1, 0, n-1, 1);
            update(a[i], 0, n-1, 1);
        }
        int tmp = total;
        for(int i=0; i<n; ++i)
        {
            total += n - a[i] - a[i] - 1;
            tmp = min(tmp, total);
        }
        printf("%d\n",tmp);
    }
    return 0;
}



posted on 2017-03-08 14:05  junior19  阅读(127)  评论(0编辑  收藏  举报