HDU Just a Hook

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9268    Accepted Submission(s): 4515


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

 

Sample Input
1 10 2 1 5 2 5 9 3
 

 

Sample Output
Case 1: The total value of the hook is 24.
 

 

Source
 

 

Recommend
wangye
 
 
View Code
#include<stdio.h>
struct SegmentTree{
    int left,right,col ;
    int mid(){    return (right + left) >> 1 ;}
    int dis(){    return (right -left + 1);}
}f[600000] ;
void build(int left,int right ,int k){
    f[k].left = left  ;
    f[k].right = right ;
    f[k].col = 1; 
    if(left == right)        return ;
    int mid = f[k].mid() ;
    build(left,mid,k<<1) ;
    build(mid+1,right,k<<1|1) ;
}
void update(int left,int right,int col,int k){
    if(left <= f[k].left && right >= f[k].right){
        f[k].col = col ;
        return ;
    }
    if(f[k].col ){
        f[k<<1|1].col = f[k<<1].col = f[k].col ;
        f[k].col = 0;
    }
    int mid = f[k].mid() ;
    if(left <= mid)
        update(left,right,col,k<<1) ;
    if(right > mid)
        update(left,right,col,k<<1|1) ;
}
int query(int left,int right,int k){
    if(f[k].col){
        return f[k].col * f[k].dis() ;
    }
    int mid = f[k].mid() ;
    return query(left,mid,k<<1) + query(mid+1,right,k<<1|1) ;
}
int main(){
    int T ;
    scanf("%d",&T) ;
    for(int cas=1;cas<=T;cas++){
        int n,m;
        scanf("%d%d",&n,&m) ;
        build(1,n,1) ;
        while(m--){
            int left,right,col ;
            scanf("%d%d%d",&left,&right,&col) ;
            update(left,right,col,1) ;
        }
        printf("Case %d: The total value of the hook is %d.\n",cas,query(1,n,1)) ;
        
    }
    return 0 ;
}

 

posted @ 2012-08-15 19:44  3111006139  阅读(134)  评论(0编辑  收藏  举报