Laughing

 

poj 1962 带路径的并查集

A very big corporation is developing its corporative network. In the beginning each of the N enterprises of the corporation, numerated from 1 to N, organized its own computing and telecommunication center. Soon, for amelioration of the services, the corporation started to collect some enterprises in clusters, each of them served by a single computing and telecommunication center as follow. The corporation chose one of the existing centers I (serving the cluster A) and one of the enterprises J in some other cluster B (not necessarily the center) and link them with telecommunication line. The length of the line between the enterprises I and J is |I – J|(mod 1000).In such a way the two old clusters are joined in a new cluster, served by the center of the old cluster B. Unfortunately after each join the sum of the lengths of the lines linking an enterprise to its serving center could be changed and the end users would like to know what is the new length. Write a program to keep trace of the changes in the organization of the network that is able in each moment to answer the questions of the users.

Input

Your program has to be ready to solve more than one test case. The first line of the input will contains only the number T of the test cases. Each test will start with the number N of enterprises (5<=N<=20000). Then some number of lines (no more than 200000) will follow with one of the commands: 
E I – asking the length of the path from the enterprise I to its serving center in the moment; 
I I J – informing that the serving center I is linked to the enterprise J. 
The test case finishes with a line containing the word O. The I commands are less than N.

Output

The output should contain as many lines as the number of E commands in all test cases with a single number each – the asked sum of length of lines connecting the corresponding enterprise with its serving center.

Sample Input

1
4
E 3
I 3 1
E 3
I 1 2
E 3
I 2 4
E 3
O

Sample Output

0
2
3
5

代码:

#include<stdio.h>
#include<math.h>
short a[20001];int w[20001];
int f(int i)
{
    if(a[i]==i) return i;
    f(a[i]);//回溯到顶点节点,然后依次往下加到i为止,i也要加

    w[i]+=w[a[i]];
    return a[i]=f(a[i]);
}
int main()
{
    int ca,n,i,j;char ch;
 scanf("%d",&ca);
 while(ca--)
 {
  scanf("%d",&n);
  for(i=1;i<=n;i++) a[i]=i,w[i]=0;
  while(getchar(),scanf("%c",&ch),ch!='O')
  {
            if(ch=='E') scanf("%d",&i),f(i),printf("%d\n",w[i]);
            else scanf("%d%d",&i,&j),a[i]=j,w[i]=abs(i-j)%1000;
  }
 }
}

posted on 2011-10-20 12:30  巨富一生  阅读(173)  评论(0编辑  收藏  举报

导航