Encoding 分类: HDU 2015-06-25 21:56 9人阅读 评论(0) 收藏

Encoding
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32145 Accepted Submission(s): 14263

Problem Description
Given a string containing only ‘A’ - ‘Z’, we could encode it using the following method:

  1. Each sub-string containing k same characters should be encoded to “kX” where “X” is the only character in this sub-string.

  2. If the length of the sub-string is 1, ‘1’ should be ignored.

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only ‘A’ - ‘Z’ and the length is less than 10000.

Output
For each test case, output the encoded string in a line.

Sample Input

2
ABC
ABBCCC

Sample Output

ABC
A2B3C

看错了题,错了好几次

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>

using namespace std;

struct AZ
{
    char s[11100];
    int num;
    int len;
    void Input()
    {
        scanf("%s",s);
    }
    void CAL()
    {
        len=strlen(s);
        for(int i=0; i<len; i++)
        {
            num=1;
            while(s[i]==s[i+1])
            {
                i++;
                num++;
            }
            if(num!=1)
            {
                cout<<num<<s[i];
            }
            else
            {
                cout<<s[i];
            }
        }
        cout<<endl;
    }

} a;
int main()
{
    int n;
    scanf("%d",&n);
    while(n--)
    {
        a.Input();
        a.CAL();
    }

    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

posted @ 2015-06-25 21:56  一骑绝尘去  阅读(133)  评论(0编辑  收藏  举报