Holedox Eating HDU4302 模拟

Problem Description
Holedox is a small animal which can be considered as one point. It lives in a straight pipe whose length is L. Holedox can only move along the pipe. Cakes may appear anywhere in the pipe, from time to time. When Holedox wants to eat cakes, it always goes to the nearest one and eats it. If there are many pieces of cake in different directions Holedox can choose, Holedox will choose one in the direction which is the direction of its last movement. If there are no cakes present, Holedox just stays where it is.
 

 

Input
The input consists of several test cases. The first line of the input contains a single integer T (1 <= T <= 10), the number of test cases, followed by the input data for each test case.The first line of each case contains two integers L,n(1<=L,n<=100000), representing the length of the pipe, and the number of events. 
The next n lines, each line describes an event. 0 x(0<=x<=L, x is a integer) represents a piece of cake appears in the x position; 1 represent Holedox wants to eat a cake.
In each case, Holedox always starts off at the position 0.
 

 

Output
Output the total distance Holedox will move. Holedox don’t need to return to the position 0.
 

 

Sample Input
3 10 8 0 1 0 5 1 0 2 0 0 1 1 1 10 7 0 1 0 5 1 0 2 0 0 1 1 10 8 0 1 0 1 0 5 1 0 2 0 0 1 1
 

 

Sample Output
Case 1: 9 Case 2: 4 Case 3: 2
 

 

Author
BUPT
 

 

Source
 

 

Recommend
zhuyuanchen520   |   We have carefully selected several similar problems for you:  4301 4303 4304 4308 4305 
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<vector>
#include<string>
#include<map>
#include<cstring>
using namespace std;
#define MAXN 500010
#define INF 0x3f3f3f3f
typedef long long LL;
/*
模拟 map每次lower_bound
*/
map<int, int> m;
int p, T, L, n, eat, tmp, ans;
int main()
{
    scanf("%d", &T);
    for(int cas = 1;cas<=T;cas++)
    {
        m.clear();
        scanf("%d%d", &L, &n);
        ans = 0, p = 0;
        int add1 ,add2;
        bool dir;
        for (int i = 0; i < n; i++)
        {
            scanf("%d", &eat);
            if (eat)
            {
                if (m.empty()) continue;
                add1 = add2 = INF;
                map<int, int>::iterator it = m.lower_bound(p);
                if (it != m.end())
                    add1 = min(add1, abs(it->first - p));
                if (it != m.begin())
                    it--, add2 = min(add2, abs(it->first - p));
                if (add1 != INF&&add1 == add2)
                {
                    if (dir) p = p + add1;
                    else p = p - add1;
                    ans += add1;
                }
                else if (add1 < add2)
                {
                    if (add1) dir = true;
                    p = p + add1, ans += add1;
                }
                else
                {
                    if (add2) dir = false;
                    p = p - add2, ans += add2;
                }
                if (--m[p] == 0)
                    m.erase(p);
            //    cout << ':' << ans <<"at" << p << endl;
            }
            else
                scanf("%d", &tmp), m[tmp]++;
        }
        printf("Case %d: %d\n", cas, ans);
    }
}

 

posted @ 2017-08-05 10:49  joeylee97  阅读(249)  评论(0编辑  收藏  举报