Fast Matrix Calculation 矩阵快速幂

One day, Alice and Bob felt bored again, Bob knows Alice is a girl who loves math and is just learning something about matrix, so he decided to make a crazy problem for her. 

Bob has a six-faced dice which has numbers 0, 1, 2, 3, 4 and 5 on each face. At first, he will choose a number N (4 <= N <= 1000), and for N times, he keeps throwing his dice for K times (2 <=K <= 6) and writes down its number on the top face to make an N*K matrix A, in which each element is not less than 0 and not greater than 5. Then he does similar thing again with a bit difference: he keeps throwing his dice for N times and each time repeat it for K times to write down a K*N matrix B, in which each element is not less than 0 and not greater than 5. With the two matrix A and B formed, Alice’s task is to perform the following 4-step calculation. 

Step 1: Calculate a new N*N matrix C = A*B. 
Step 2: Calculate M = C^(N*N). 
Step 3: For each element x in M, calculate x % 6. All the remainders form a new matrix M’. 
Step 4: Calculate the sum of all the elements in M’. 

Bob just made this problem for kidding but he sees Alice taking it serious, so he also wonders what the answer is. And then Bob turn to you for help because he is not good at math.

InputThe input contains several test cases. Each test case starts with two integer N and K, indicating the numbers N and K described above. Then N lines follow, and each line has K integers between 0 and 5, representing matrix A. Then K lines follow, and each line has N integers between 0 and 5, representing matrix B. 

The end of input is indicated by N = K = 0.OutputFor each case, output the sum of all the elements in M’ in a line.Sample Input

4 2
5 5
4 4
5 4
0 0
4 2 5 5
1 3 1 5
6 3
1 2 3
0 3 0
2 3 4
4 3 2
2 5 5
0 5 0
3 4 5 1 1 0
5 3 2 3 3 2
3 1 5 4 5 2
0 0

Sample Output

14
56



C = A*B
C^1000 = A*(B*A)^999*B

简化到k*k上的矩阵计算方便
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<sstream>
#include<algorithm>
#include<queue>
#include<deque>
#include<iomanip>
#include<vector>
#include<cmath>
#include<map>
#include<stack>
#include<set>
#include<fstream>
#include<memory>
#include<list>
#include<string>
using namespace std;
typedef long long  LL;
typedef unsigned long long ULL;
#define MAXN 1007
#define MOD 10000007
#define INF 1000000009
const double eps = 1e-9;
int n, k;
struct Mat
{
	int a[10][10];
	Mat()
	{
		memset(a, 0, sizeof(a));
	}
	Mat operator * (const Mat& rhs)const
	{
		Mat ret;
		for (int i = 0; i < k; i++)
		{
			for (int j = 0; j < k; j++)
			{
				if (a[i][j])
				{
					for (int t = 0; t < k; t++)
					{
						ret.a[i][t] = (ret.a[i][t] + a[i][j] * rhs.a[j][t]) % 6;
					}
				}
			}
		}
		return ret;
	}
};
Mat fpow(Mat a, int b)
{
	Mat ret;
	for (int i = 0; i < k; i++)
		ret.a[i][i] = 1;
	while (b != 0)
	{
		if (b & 1)
			ret = a*ret;
		a = a*a;
		b /= 2;
	}
	return ret;
}
int m1[MAXN][7], m2[7][MAXN], ans[MAXN][MAXN], tmp[MAXN][MAXN];
int main()
{
	while (scanf("%d%d", &n, &k), n + k)
	{
		for (int i = 0; i < n; i++)
			for (int j = 0; j < k; j++)
				scanf("%d", &m1[i][j]);
		for (int i = 0; i < k; i++)
			for (int j = 0; j < n; j++)
				scanf("%d", &m2[i][j]);
		Mat M;
		for (int i = 0; i < k; i++)
		{
			for (int j = 0; j < k; j++)
			{
				for (int t = 0; t < n; t++)
				{
					M.a[i][j] = (M.a[i][j] + m2[i][t] * m1[t][j])%6;
				}
			}
		}
		M = fpow(M, n*n - 1);
		memset(tmp, 0, sizeof(tmp));
		memset(ans, 0, sizeof(ans));
		for (int i = 0; i < n; i++)
		{
			for (int j = 0; j < k; j++)
			{
				for (int t = 0; t < k; t++)
					tmp[i][j] = (tmp[i][j] + m1[i][t] * M.a[t][j])%6;
			}
		}
		for (int i = 0; i < n; i++)
		{
			for (int j = 0; j < n; j++)
			{
				for (int t = 0; t < k; t++)
					ans[i][j] = (ans[i][j] + tmp[i][t] * m2[t][j])%6;
			}
		}
		int res = 0;
		for (int i = 0; i < n; i++)
			for (int j = 0; j < n; j++)
				res += ans[i][j]%6;
		printf("%d\n", res);
	}
}

 

 

 

posted @ 2017-07-28 15:13  joeylee97  阅读(442)  评论(0编辑  收藏  举报