给出一个字符串,求该字符串的一个子串s,s包含A-Z中的全部字母,并且s是所有符合条件的子串中最短的,输出s的长度。如果给出的字符串中并不包括A-Z中的全部字母,则输出No Solution。

Input

第1行,1个字符串。字符串的长度 <= 100000。

Output

输出包含A-Z的最短子串s的长度。如果没有符合条件的子串,则输出No Solution。

Sample Input

BVCABCDEFFGHIJKLMMNOPQRSTUVWXZYZZ

Sample Output

28
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
int g[27]={0};
int cc()
{
    int i;
    for(i=1;i<=26;i++)
        if(g[i]==0)
          break;
    if(i==27)
        return 1;
    else
        return 0;
}
int main()
{
    int i,j,k,l;
    char a[100100];
    gets(a);
    int len=strlen(a);
    int st=0,en=0,minn;
    minn=1e6;
    for(i=0;i<len;i++)
    {
        g[a[i]-64]++;
        while(cc())
        {
            minn=min(minn,i-st+1);
            g[a[st]-64]--;
            st++;
        }
    }
    if(minn==1e6)
        printf("No Solution\n");
    else
        printf("%d\n",minn);
    return 0;
}