poj-2909-哥德巴赫猜想

Description

For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that

n = p1 + p2

This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. There can be many such numbers. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.

Input

An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 215. The end of the input is indicated by a number 0.

Output

Each output line should contain an integer number. No other characters should appear in the output.

Sample Input

6
10
12
0

Sample Output

1
2
1
题目大意:

对于任何偶数n大于等于4,至少存在一个质数p1和p2这样

 

n = p1和p2

 

这个猜想尚未证明也不拒绝。没人知道是否这个猜想成立。然而,人们可以发现这样一双质数,如果有的话,对于给定的一个偶数。这里的问题是编写一个程序,报告所有成对的质数的数量满足条件给定的一个偶数的猜想。

 

给出一个偶数序列作为输入。可以有许多这样的数字。对应于每个数字,程序应该输出对上面提到的数量。注意,我们感兴趣的数量对本质上是不同的,因此你不应计数(p1,p2)和(p2,p1)分别作为两个不同的配对。

#include<iostream>
using namespace   std;
bool   aa(int b)   //判断质数函数
{
    for(int i=3;i*i<=b;i++)
    {
        if(b%i==0)return 0;
    }
    return 1;
}

int main()
{
    int a;
    cin>>a;
    while(a)
    {
        int q=0;
     for(int j=3;j*2<=a;j+=2)//排除偶数,减少时间消耗
     {
         if(aa(j)&&aa(a-j))
            q++;
     }
    cout<<q<<endl;
    cin>>a;
    }




    return 0;
}

  

posted @ 2016-03-15 21:15  |瑾诺学长|  阅读(269)  评论(0编辑  收藏  举报