HDU 4251 The Famous ICPC Team Again(划分树)

The Famous ICPC Team Again

Time Limit: 30000/15000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1440    Accepted Submission(s): 708


Problem Description
When Mr. B, Mr. G and Mr. M were preparing for the 2012 ACM-ICPC World Final Contest, Mr. B had collected a large set of contest problems for their daily training. When they decided to take training, Mr. B would choose one of them from the problem set. All the problems in the problem set had been sorted by their time of publish. Each time Prof. S, their coach, would tell them to choose one problem published within a particular time interval. That is to say, if problems had been sorted in a line, each time they would choose one of them from a specified segment of the line.

Moreover, when collecting the problems, Mr. B had also known an estimation of each problem’s difficultness. When he was asked to choose a problem, if he chose the easiest one, Mr. G would complain that “Hey, what a trivial problem!”; if he chose the hardest one, Mr. M would grumble that it took too much time to finish it. To address this dilemma, Mr. B decided to take the one with the medium difficulty. Therefore, he needed a way to know the median number in the given interval of the sequence.
 

 

Input
For each test case, the first line contains a single integer n (1 <= n <= 100,000) indicating the total number of problems. The second line contains n integers xi (0 <= xi <= 1,000,000,000), separated by single space, denoting the difficultness of each problem, already sorted by publish time. The next line contains a single integer m (1 <= m <= 100,000), specifying number of queries. Then m lines follow, each line contains a pair of integers, A and B (1 <= A <= B <= n), denoting that Mr. B needed to choose a problem between positions A and B (inclusively, positions are counted from 1). It is guaranteed that the number of items between A and B is odd.
 

 

Output
For each query, output a single line containing an integer that denotes the difficultness of the problem that Mr. B should choose.
 

 

Sample Input
5 5 3 2 4 1 3 1 3 2 4 3 5 5 10 6 4 8 2 3 1 3 2 4 3 5
 

 

Sample Output
Case 1: 3 3 2 Case 2: 6 6 4
【分析】划分树水题
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <time.h>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#define met(a,b) memset(a,b,sizeof a)
#define pb push_back
#define lson(x) ((x<<1))
#define rson(x) ((x<<1)+1)
using namespace std;
typedef long long ll;
const int N=1e5+50;
const int M=N*N+10;
struct P_Tree {
    int n;
    int tree[20][N];
    int sorted[N];
    int toleft[20][N];
    void init(int len) {
        n=len;
        for(int i=0; i<20; i++)tree[i][0]=toleft[i][0]=0;
        for(int i=1; i<=n; i++) {
            scanf("%d",&sorted[i]);
            tree[0][i]=sorted[i];
        }
        sort(sorted+1,sorted+n+1);
        build(1,n,0);
    }
    void build(int l,int r,int dep) {
        if(l==r)return;
        int mid=(l+r)>>1;
        int same=mid-l+1;
        for(int i=l; i<=r; i++)
            if(tree[dep][i]<sorted[mid])
                same--;
        int lpos=l;
        int rpos=mid+1;
        for(int i=l; i<=r; i++) {
            if(tree[dep][i]<sorted[mid]) { //去左边
                tree[dep+1][lpos++]=tree[dep][i];

            } else if(tree[dep][i]==sorted[mid]&&same>0) { //去左边
                tree[dep+1][lpos++]=tree[dep][i];
                same--;
            } else //去右边
                tree[dep+1][rpos++]=tree[dep][i];
            toleft[dep][i]=toleft[dep][l-1]+lpos-l;//从1到i放左边的个数
        }
        build(l,mid,dep+1);//递归建树
        build(mid+1,r,dep+1);
    }
    int query(int L,int R,int l,int r,int dep,int k) {
        if(l==r)return tree[dep][l];
        int mid=(L+R)>>1;
        int cnt=toleft[dep][r]-toleft[dep][l-1];
        if(cnt>=k) {
            //L+查询区间前去左边的数的个数
            int newl=L+toleft[dep][l-1]-toleft[dep][L-1];
            //左端点+查询区间会分入左边的数的个数
            int newr=newl+cnt-1;
            return query(L,mid,newl,newr,dep+1,k);//注意
        } else {
            //r+区间后分入左边的数的个数
            int newr=r+toleft[dep][R]-toleft[dep][r];
            //右端点减去区间分入右边的数的个数
            int newl=newr-(r-l-cnt);
            return query(mid+1,R,newl,newr,dep+1,k-cnt);//注意
        }
    }
}tre;
int main() {
    int iCase=0;
    int n,m;
    int u,v;
    while(~scanf("%d",&n)) {
        tre.init(n);
        scanf("%d",&m);
        printf("Case %d:\n",++iCase);
        while(m--) {
            scanf("%d%d",&u,&v);
            int k=(v-u)/2+1;
            printf("%d\n",tre.query(1,n,u,v,0,k));
        }
    }
    return 0;
}

 

posted @ 2017-02-03 23:43  贱人方  阅读(190)  评论(0编辑  收藏  举报