POJ 3928 Ping pong(树状数组)

                                                                      Ping pong
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3139   Accepted: 1157

Description

N(3<=N<=20000) ping pong players live along a west-east street(consider the street as a line segment). Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee's house. For some reason, the contestants can't choose a referee whose skill rank is higher or lower than both of theirs. The contestants have to walk to the referee's house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?

Input

The first line of the input contains an integer T(1<=T<=20), indicating the number of test cases, followed by T lines each of which describes a test case.
Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N distinct integers a1, a2 ... aN follow, indicating the skill rank of each player, in the order of west to east. (1 <= ai <= 100000, i = 1 ... N).

Output

For each test case, output a single line contains an integer, the total number of different games.

Sample Input

1 
3 1 2 3

Sample Output

1
【分析】没想到此题可以用树状数组做。首先用结构体记录输入数字的大小及下标,然后按数值从小到大排序。然后枚举中间数字,及a[i]<a[k]<a[j]中的a[k]。然后用排序后的数组依次计算,树状数组tree记录的是
到当前位置已经出现过的数的数目,那么到后面,这些数自然就比他小了,感觉很神奇。
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#define inf 0x3f3f3f3f
#define met(a,b) memset(a,b,sizeof a)
#define pb push_back
typedef long long ll;
using namespace std;
const int N = 2e4+10;
const int M = 24005;
const int mod=1e9+7;
int tree[N],n,m;
struct man{
    int pos,rank;
    bool operator< (const man &it)const{
        return rank<it.rank;
    }
};
void add(int k,int num){
    while(k<=n){
        tree[k]+=num;
        k+=k&(-k);
    }
}
int Sum(int k){
    int sum=0;
    while(k>0){
        sum+=tree[k];
        k-=k&(-k);
    }
    return sum;
}
int main() {
    int t;
    scanf("%d",&t);
    while(t--){
        met(tree,0);
        man a[N];
        ll ans=0;
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i].rank);
            a[i].pos=i;
        }
        sort(a+1,a+n+1);
        add(a[1].pos,1);
        for(int i=2;i<n;++i){
            int ls,lb,rs,rb;
            ls=Sum(a[i].pos-1);
            lb=a[i].pos-1-ls;
            rs=Sum(n)-Sum(a[i].pos);
            rb=n-rs-a[i].pos;
            ans+=ls*rb+lb*rs;
            add(a[i].pos,1);
        }
        printf("%lld\n",ans);
    }
    return 0;
}

 

posted @ 2016-11-15 20:55  贱人方  阅读(203)  评论(0编辑  收藏  举报