HDU2057 A + B Again(十六进制加法运算)

Problem Description

There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !

Input

The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.

Output

For each test case,print the sum of A and B in hexadecimal in one line.

Sample Input

+A -A +1A 12 1A -9 -1A -12 1A -AA

Sample Output

0 2C 11 -2C -90

 

ps:没看讨论区之前我正在纠结如何将十六进制转成十进制运算再转回到十六进制输出。。。

#include <cstdio>
#include <iostream>
using namespace std;
typedef long long ll;
int main(){
    ll a,b;
    while(scanf("%llX %llX",&a,&b)!=EOF){
        a+=b;
        if(a>=0) printf("%llX\n",a);
        else {
            a=-a;
            printf("-%llX\n",a);
        }
    }
    return 0;
}
posted @ 2019-08-16 20:22  yyer  阅读(179)  评论(0编辑  收藏  举报