HDU1002 Problem II(大数相加)(C++题解)

A题 HDOJ1002(大数加法)

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 483720    Accepted Submission(s): 93351

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2 1 2 112233445566778899 998877665544332211

Sample Output

Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

 

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main(){
    char a[8000],b[8000];
    int an[8000],bn[8000],sum[8000],pre,flag=1;
    int t;
    scanf("%d",&t);
    while(t--){
    memset(an,0,sizeof(an));
    memset(bn,0,sizeof(bn));
    memset(sum,0,sizeof(sum));
        scanf("%s%s",a,b);
        int len1=strlen(a);
        int len2=strlen(b);
        int len=(len1>len2)?len1:len2;
        pre=0;
        for(int i=0;i<len1;i++){
            an[len1-i-1]=a[i]-'0';
        }
        for(int j=0;j<len2;j++){
            bn[len2-j-1]=b[j]-'0';
        }
        for(int k=0;k<len;k++){
            sum[k]=an[k]+bn[k]+pre/10;
            pre=sum[k];
        }
        if(pre>9){
            sum[len]=pre/10%10;
            len++;
            pre/=10;
        }
        printf("Case %d:\n",flag++);
        printf("%s + %s = ",a,b);
        for(int s=0;s<len;s++){
            printf("%d",sum[len-s-1]%10);
        }
        printf("\n");
        if(t){
            
            printf("\n");
        }
    }
    return 0;
}
posted @ 2019-07-16 15:52  yyer  阅读(222)  评论(0编辑  收藏  举报