hdu1205(类似 分布垃圾数列)

Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

 

Input
Each line will contain an integers. Process to end of file.
 

 

Output
For each case, output the result in a line.
 

 

Sample Input
100
 

 

Sample Output
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int f[7050][500],len[1000],i,j,e,c,n;

int main()
{
    memset(f,0,sizeof(f));
    f[1][0]=f[2][0]=f[3][0]=f[4][0]=1;
    len[1]=len[2]=len[3]=len[4]=1;
    for(i=5;i<7050;i++)
    {
        c=0;
        for(j=0;j<500;j++)
        {
                f[i][j]=f[i-1][j]+f[i-2][j]+f[i-3][j]+f[i-4][j]+c;
                c=f[i][j]/100000000;//这样可以节少空间的使用
                f[i][j]%=100000000;
        }
    }

    while(cin>>n)
    {
        for(e=499;e>=0;e--)
        if(f[n][e])
        break;
        printf("%d",f[n][e--]);
        for(;e>=0;e--)
        printf("%08d",f[n][e]);//一定要注意补0,因为在上面取余时,如21000003234498%10000000=3234498
        cout<<endl;
    }
}


 
posted @ 2013-07-22 19:56  坚固66  阅读(248)  评论(0编辑  收藏  举报