程序语言POJ 2406 Power Strings

在本文中,我们主要介绍程序语言的内容,自我感觉有个不错的提议和大家分享下

    

Power Strings

    

Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 26177   Accepted: 10976

    Description

    

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

    Input

    

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

    Output

    

For each s you should print the largest n such that s = a^n for some string a.

    Sample Input

abcd
aaaa
ababab
.

    Sample Output

1
4
3

    Hint

    

This problem has huge input, use scanf instead of cin to avoid time limit exceed.
    每日一道理
聪明人学习,像搏击长空的雄鹰,仰视一望无际的大地;愚笨的人学习,漫无目的,犹如乱飞乱撞的无头飞蛾;刻苦的人学习,像弯弯的河流,虽有曲折,但终会流入大海;懒惰的人学习,像水中的木头,阻力越大倒退得越快。

    Source

    

    

   其实这道标题的路思来自POJ 1961,提议先做做1961,做完以后这道标题就会很易容的决解了
/***************************************************************
 > File Name: E:\我的程序\C语言\power.c
 > Author: SDUT_GYX
 > Mail: 2272902662@qq.com
 > Created Time: 2013/5/9 10:14:47
 **************************************************************/

#include<stdio.h>
#include <string.h>
#include <math.h>
char s1[1100000];
int next[1100000],dp[1100000];
int main()
{
	void get_next(int l);
	int i,j,n,m,s,t,l;
	while(gets(s1))
	{
        if(strcmp(s1,".")==0)
		{
			break;
		}
		l=strlen(s1);
		get_next(l);
		dp[0]=0;
		for(i=2;i<=l;i++)
		{
		   n=next[i];
		   if(n+n==i)
		   {
			   dp[i-1]=n;
		   }else if(n+n<i)
		   {
			   dp[i-1]=0;
		   }else
		   {
			   dp[i-1]=dp[n-1];
		   }
		}
		if(dp[l-1]==0)
		{
			printf("1\n");
		}else
		{
			printf("%d\n",l/dp[l-1]);
		}
	}
	return 0;
}
void get_next(int l)
{
	int i,j;
	next[0]=-1;
	next[1]=0;
	for(i=2,j=0;i<=l;)
	{
		if(j==-1||s1[i-1]==s1[j])
		{
			i++;j++;
			next[i-1]=j;
		}else
		{
			j=next[j];
		}
	}
}

文章结束给大家分享下程序员的一些笑话语录: 面试官:熟悉哪种语言
应聘者:JAVA
面试官:知道什么叫类么
应聘者:我这人实在,工作努力,不知道什么叫累
面试官:知道什么是包?
应聘者:我这人实在 平常不带包 也不用公司准备了
面试官:知道什么是接口吗?
应聘者:我这个人工作认真。从来不找借口偷懒
面试官:知道什么是继承么
应聘者:我是孤儿没什么可以继承的
面试官:知道什么叫对象么?
应聘者:知道,不过我工作努力,上进心强,暂时还没有打算找对象。
面试官:知道多态么?
应聘者:知道,我很保守的。我认为让心爱的女人为了自已一时的快乐去堕胎是不道德的行为!请问这和C#有什么关系??

posted @ 2013-05-09 19:34  坚固66  阅读(148)  评论(0编辑  收藏  举报