nullnullhdu2134(切蛋糕)

本文是一篇关于nullnull的帖子

    

Problem Description

    

Ice cream took a bronze medal in the Beijing match. Liu sir is very very happy. So he buys a cake for them. kiki is a child who likes eating, so the task of cuting cake was given to kiki. kiki is also a mischievous child. She wants to cut the cake in a different way. This is introduced in the figure below.
null和null

But there is a difficult problem.which is how to make each preson get equally many cake. kiki is not good at match, so she wants you help her solve this problem.

    

 

    

Input

    

Input contains multiple test cases. Each line is a case. Each case contains only one integer R which is the radius. The input is terminated with a R of 0.

    

 
    每日一道理
流逝的日子像一片片凋零的枯叶与花瓣,渐去渐远的是青春的纯情与浪漫。不记得曾有多少雨飘在胸前风响在耳畔,只知道沧桑早已漫进了我的心爬上了我的脸。当一个人与追求同行,便坎坷是伴,磨难也是伴。

    

Output

    

For each test case, you should printf two numbers r2 and r1 in a line, accurate up to 3 decimal places, separate them by one space.

    

 

    

Sample Input
10 15 5 25 0
 

    

Sample Output
5.774 8.165
8.660 12.247
2.887 4.082
14.434 20.412

 

#include<stdio.h>
#include<math.h>
int main()
{
    double R,r1,r2;
    while (scanf("%lf",&R)==1&&R)
    {
        r2=R*sqrt(2.0/3);
        r1=R*sqrt(1.0/3);
        printf("%.3lf %.3lf\n",r1,r2);
    }
    return 0;
}

    
 

文章结束给大家分享下程序员的一些笑话语录: 《诺基亚投资手机浏览器UCWEB,资金不详或控股》杯具了,好不容易养大的闺女嫁外国。(心疼是你养的吗?中国创业型公司创业初期哪个从国有银行贷到过钱?)

posted @ 2013-05-22 21:52  坚固66  阅读(154)  评论(0编辑  收藏  举报