poj 3252 Round Numbers

B - Round Numbers
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start..Finish

Sample Input

2 12

Sample Output

6

题意:输入两个十进制正整数a和b,求闭区间[a ,b]内有多少个Round number;0的个数大于等于1的为round数

#include <stdio.h>
int c[40][40];
int bin[40];
int max( int x,int y)
{
  if(x<y) return y;
  return x;
}
void init( )
{
 c[0][0]=1;
 for( int i=1;i<=32;i++)
 {
   c[i][0]=1;
   for( int j=1;j<=i;j++)
    c[i][j]=c[i-1][j]+c[i-1][j-1];
 }
}
int rounder( int n)
{
  int len=0;
  while(n)
  {
    bin[++len]=n%2;
    n/=2;
  }
  int i,j,sum=0;
  /*计算长度小于bin[0]的所有二进制数中RN的个数*/
 for( i=1;i<len;i++)
  {
    for( j=(i+1)/2;j<i;j++)
     sum+=c[i-1][j];
  }
  /*计算长度等于bin[0]的所有二进制数中RN的个数*/
  int zero=0;
  for( i=len-1;i>0;i--)
  {
     if(bin[i])
     {
     zero++;
    for( j=max(0,(len+1)/2-zero);j<i;j++)
    {
    sum+=c[i-1][j];
       }
         zero--;
  }
  else zero++;
  }
  return sum;
}
int main( )
{
  init( );
  int a,b;
  while(~scanf("%d%d",&a,&b))
  {
   
  printf("%d\n",rounder(b+1)-rounder(a));
  }
 
  return 0;
 
}

链接:http://poj.org/problem?id=3252
参考资料:
//http://hi.baidu.com/lxyzmnwvhokptur/item/33ddd66a3b9c8699c5d24919
//http://blog.csdn.net/acm_cxlove/article/details/7855433

posted @ 2012-09-17 21:50  jiai  Views(151)  Comments(0Edit  收藏  举报