poj 2352 Stars

Stars
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 22249   Accepted: 9689

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source

题意:给定坐标点(整数),让你统计这个点的左下方有多少个点。
因为星星是先按y的升序再按x的升序给出的,所以之后的星星不会影响前面的星星的层次。(这是前提)用树状数组统计小于等于当前星星x坐标的星星个数即为level.

树状数组的做法是,每读入一组坐标,先算出其level,再更新数组.最后输出的是各level星星数.注意树状数组是从1开始的所以x要+1.数组也不要开小.

AC代码:

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define maxn 32060
int c[maxn];
int level[maxn];
int n;
int lowbit( int i)
{
 return i&(-i);
}
void updata( int i)
{
  while(i<=maxn)
  {
 c[i]+=1;
 i+=lowbit(i);
  }
}
int sum( int i)
{
  int s=0;
  while(i>0)
  {
 s+=c[i];
 i-=lowbit(i);
  }
  return s;
}
int main( )
{
  memset(c,0,sizeof(c));
  memset(level,0,sizeof(c));
  scanf("%d",&n);
  for(int  i=0;i<n;i++)
  {
 int x,y;scanf("%d%d",&x,&y);
 ++x;
 ++level[sum(x)];
   //printf("sum = %d level[sum(%d)] = %d\n",sum(x),x,++level[sum(x)]);
 
 updata(x);
  }
  for(int i=0;i<n;i++)
  {
 printf("%d\n",level[i]);
  }
 // system("pause");
  return 0;
}

链接:http://poj.org/problem?id=2352

posted @ 2012-08-03 15:47  jiai  Views(181)  Comments(0Edit  收藏  举报