poj 3259 Wormholes

Wormholes
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 20003   Accepted: 7088

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: N, M, and W 
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

题意:John的农场里N块地,M条路连接两块地,W个虫洞;路是双向的,虫洞是一条单向路,会在你离开之前把你传送到目的地,
就是当你过去的时候时间会倒退Ts。我们的任务是知道会不会在从某块地出发后又回来,看到了离开之前的自己。
简化下,就是看图中有没有负权环。
思路: 做spfa时,  当一个点入队列次数>=n, 说明存在负权回路

存在负权回路输出YES, 否则NO. 

AC代码:
#include <stdio.h>
#include <string.h>
#include <vector>
#include <queue>
#define INF 1000000000
using namespace std;
struct node
{
 int to;
 int w;
}tedge;
vector<node>edge[600];
int vis[600],cnt[600];
int dis[600];
int n,m,t;
void add( int a,int b,int c)
{
 tedge.to=b;
 tedge.w=c;
 edge[a].push_back(tedge);
}
int spfa( int s)
{
  int i;
  queue<int>q;
  memset(vis,0,sizeof(vis));
  memset(cnt,0,sizeof(cnt));
  dis[s]=0;
  vis[s]=1;
  q.push(s);
  while(!q.empty( ))
  {
 int u=q.front( );
 q.pop( );
 vis[u]=0;
 for( i=0;i<edge[u].size( );i++)
 {
   if(dis[edge[u][i].to]-edge[u][i].w>dis[u])
   {
   dis[edge[u][i].to]=edge[u][i].w+dis[u];
   if(!vis[edge[u][i].to])
   {
   q.push(edge[u][i].to);
   vis[edge[u][i].to]=1;
   if(++cnt[edge[u][i].to]>n)
    return -1;
   }
   }
  
    }
  }
  return 1;
}
int main( )
{
  int s,e,tt,i;
  int test;
  scanf("%d",&test);
  while(test--)
  {
    scanf("%d%d%d",&n,&m,&t);
    for( i=1;i<=n;i++)
     dis[i]=INF;
    for( i=1;i<=n;i++)
     edge[i].clear( );
    while(m--)
    {
   scanf("%d%d%d",&s,&e,&tt);
   add(s,e,tt);
   add(e,s,tt);
 }
 while(t--)
 {
   scanf("%d%d%d",&s,&e,&tt);
   add(s,e,-tt);
    }
    for( i=1;i<=n;i++)
    {
   if(dis[i]>=INF)
   {
  int ret=spfa(i);
  if(ret==-1) break;
   }
 }
 if(i<=n) printf("YES\n");
 else printf("NO\n");
 
  }
  return 0;
}
 
posted @ 2012-07-27 21:17  jiai  Views(135)  Comments(0Edit  收藏  举报