hdu A Famous Stone Collector

A Famous Stone Collector


Problem Description

Mr. B loves to play with colorful stones. There are n colors of stones in his collection. Two stones with the same color are indistinguishable. Mr. B would like to 
select some stones and arrange them in line to form a beautiful pattern. After several arrangements he finds it very hard for him to enumerate all the patterns. So he asks you to write a program to count the number of different possible patterns. Two patterns are considered different, if and only if they have different number of stones or have different colors on at least one position.
 

 

Input
Each test case starts with a line containing an integer n indicating the kinds of stones Mr. B have. Following this is a line containing n integers - the number of 
available stones of each color respectively. All the input numbers will be nonnegative and no more than 100.
 

 

Output
For each test case, display a single line containing the case number and the number of different patterns Mr. B can make with these stones, modulo 1,000,000,007, 
which is a prime number.
 

 

Sample Input
3 1 1 1 2 1 2
 

 

Sample Output
Case 1: 15 Case 2: 8
Hint
In the first case, suppose the colors of the stones Mr. B has are B, G and M, the different patterns Mr. B can form are: B; G; M; BG; BM; GM; GB; MB; MG; BGM; BMG; GBM; GMB; MBG; MGB.

 

给定n种颜色的石头,每种颜色有si颗,同种颜色的石头不区分。问能构成多少种不同的石头序列(不同的序列是指:1.石头数不同;2.石头数相同,至少一个位置的石头颜色不同)

Ways[i]表示选i个石头的不同种类

其中C[ n ][ m ]表示组合数。

AC代码:

#include <stdio.h>
#include <string.h>
#define mod 1000000007
long long c[100005][150];
long long ways[100005];
long long a[100005];
void init( )
{
c[0][0]=1;
for( int i=1;i<=10000;i++)
{
c[i][0]=1;
for( int j=1;j<=100&&j<=i;j++)
{
c[i][j]=(c[i-1][j]+c[i-1][j-1])%mod;
}
}
}
int main( )
{
int i,j,u;
int n,total;
int m=1;
init( );
while(scanf("%d",&n)!=EOF)
{
for( i=0;i<n;i++)
{
scanf("%lld",&a[i]);
}
memset(ways,0,sizeof(ways));
total=0;
ways[0]=1;
for( i=0;i<n;i++)
{
total+=a[i];
for( j=total;j>=0;j--)
{
for(u=1;u<=a[i];u++)
{
ways[j]+=ways[j-u]*c[j][u];
ways[j]%=mod;
}
}
}
long long ans=0;
for( i=1;i<=total;i++)
{
ans=(ans+ways[i])%mod;
}
printf("Case %lld: %d\n",m++,ans);
}
return 0;
}

链接:http://acm.hdu.edu.cn/showproblem.php?pid=4248

posted @ 2012-07-24 17:37  jiai  Views(230)  Comments(0Edit  收藏  举报