hdu 6199 gems gems gems dp

gems gems gems

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)



Problem Description
Now there are n gems, each of which has its own value. Alice and Bob play a game with these n gems.
They place the gems in a row and decide to take turns to take gems from left to right. 
Alice goes first and takes 1 or 2 gems from the left. After that, on each turn a player can take k or k+1 gems if the other player takes k gems in the previous turn. The game ends when there are no gems left or the current player can't take k or k+1 gems.
Your task is to determine the difference between the total value of gems Alice took and Bob took. Assume both players play optimally. Alice wants to maximize the difference while Bob wants to minimize it.
 

 

Input
The first line contains an integer T (1T10), the number of the test cases. 
For each test case:
the first line contains a numbers n (1n20000);
the second line contains n numbers: V1,V2Vn. (100000Vi100000)
 

 

Output
For each test case, print a single number in a line: the difference between the total value of gems Alice took and the total value of gems Bob took.
 

 

Sample Input
1 3 1 3 2
 

 

Sample Output
4
 

 

Source

思路:dp,蜜汁题意;滚动数组优化空间;

#include<bits/stdc++.h>
using namespace std;

const int N=2e4+10,M=2e6+10,inf=1e9+10;

int dp[2][1010][201],n,sum[N];

int main()
{
    int T,x;
    scanf("%d",&T);
    while(T--)
    {
        memset(dp,0,sizeof(dp));
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d",&x),sum[i]=sum[i-1]+x;
        for(int i=n;i>=1;i--)
        {
            for(int j=200;j>=1;j--)
            {
                if(i+j<=n)
                {
                    dp[0][i%1000][j]=max(sum[i+j-1]-sum[i-1]+dp[1][(i+j)%1000][j],sum[i+j]-sum[i-1]+dp[1][(i+j+1)%1000][j+1]);
                    dp[1][i%1000][j]=min(-sum[i+j-1]+sum[i-1]+dp[0][(i+j)%1000][j],-sum[i+j]+sum[i-1]+dp[0][(i+j+1)%1000][j+1]);
                }
                else if(i+j-1<=n)
                {
                    dp[0][i%1000][j]=dp[1][(i+j)%1000][j]+sum[i+j-1]-sum[i-1];
                    dp[1][i%1000][j]=dp[0][(i+j)%1000][j]-sum[i+j-1]+sum[i-1];
                }
            }
        }
        printf("%d\n",dp[0][1][1]);
    }
    return 0;
}

 

 

gems gems gems

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 625    Accepted Submission(s): 77


Problem Description
Now there are n gems, each of which has its own value. Alice and Bob play a game with these n gems.
They place the gems in a row and decide to take turns to take gems from left to right. 
Alice goes first and takes 1 or 2 gems from the left. After that, on each turn a player can take k or k+1 gems if the other player takes k gems in the previous turn. The game ends when there are no gems left or the current player can't take k or k+1 gems.
Your task is to determine the difference between the total value of gems Alice took and Bob took. Assume both players play optimally. Alice wants to maximize the difference while Bob wants to minimize it.
 

 

Input
The first line contains an integer T (1T10), the number of the test cases. 
For each test case:
the first line contains a numbers n (1n20000);
the second line contains n numbers: V1,V2Vn. (100000Vi100000)
 

 

Output
For each test case, print a single number in a line: the difference between the total value of gems Alice took and the total value of gems Bob took.
 

 

Sample Input
1 3 1 3 2
 

 

Sample Output
4
 

 

Source
posted @ 2017-09-11 15:06  jhz033  阅读(199)  评论(0编辑  收藏  举报