hdu 5777 domino 贪心

domino

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)


Problem Description
Little White plays a game.There are n pieces of dominoes on the table in a row. He can choose a domino which hasn't fall down for at most k times, let it fall to the left or right. When a domino is toppled, it will knock down the erect domino. On the assumption that all of the tiles are fallen in the end, he can set the height of all dominoes, but he wants to minimize the sum of all dominoes height. The height of every domino is an integer and at least 1.
 

 

Input
The first line of input is an integer T ( 1T10)
There are two lines of each test case.
The first line has two integer n and k, respectively domino number and the number of opportunities.( 2k,n100000)
The second line has n - 1 integers, the distance of adjacent domino d, 1d100000
 

 

Output
For each testcase, output of a line, the smallest sum of all dominoes height
 

 

Sample Input
1 4 2 2 3 4
 

 

Sample Output
9
 

 

Source

BestCoder Round #85

思路:每次多推一次将最大的改成高度为1的骨牌;

   坑点:k可能大于n;

#include<bits/stdc++.h>
using namespace std;
#define ll __int64
#define esp 0.00000000001
const int N=1e5+10,M=1e6+10,inf=1e9+10,mod=1000000007;
int a[N];
int main()
{
    int x,y,z,i,t;
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&x,&y);
        for(i=1;i<x;i++)
            scanf("%d",&a[i]);
        sort(a+1,a+x);
        ll ans=0;
        for(i=1;i<=(x-y);i++)
        ans+=a[i]+1;
        if(y<=x)
        ans+=y;
        else
        ans+=x;
        printf("%I64d\n",ans);
    }
    return 0;
}

 

posted @ 2016-08-03 15:03  jhz033  阅读(195)  评论(0编辑  收藏  举报