hdu 5391 Zball in Tina Town 威尔逊定理 数学

Zball in Tina Town

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)


Problem Description
Tina Town is a friendly place. People there care about each other.

Tina has a ball called zball. Zball is magic. It grows larger every day. On the first day, it becomes 1 time as large as its original size. On the second day,it will become 2 times as large as the size on the first day. On the n-th day,it will become n times as large as the size on the (n-1)-th day. Tina want to know its size on the (n-1)-th day modulo n.
 

 

Input
The first line of input contains an integer T, representing the number of cases.

The following T lines, each line contains an integer n, according to the description.
T105,2n109
 

 

Output
For each test case, output an integer representing the answer.
 

 

Sample Input
2 3 10
 

 

Sample Output
2 0
 

 

Source
 思路:当数为素数时,威尔逊;
    当数为非素数,4输出2;
          别的输出0;
#include<bits/stdc++.h>
using namespace std;
#define ll __int64
#define esp 0.00000000001
const int N=1e3+10,M=1e6+10,inf=1e9+10,mod=1000000007;
int prime(int n)
{
    if(n<=1)
    return 0;
    if(n==2)
    return 1;
    if(n%2==0)
    return 0;
    int k, upperBound=n/2;
    for(k=3; k<=upperBound; k+=2)
    {
        upperBound=n/k;
        if(n%k==0)
            return 0;
    }
    return 1;
}
int main()
{
    int x,y,z,i,t;
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&x);
        if(x==4)
        printf("2\n");
        else if(prime(x))
        printf("%d\n",x-1);
        else
        printf("0\n");
    }
    return 0;
}

 

 

posted @ 2016-07-20 12:33  jhz033  阅读(214)  评论(0编辑  收藏  举报