poj2262

                                                                                               Goldbach's Conjecture
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 36877   Accepted: 14119

Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture:
Every even number greater than 4 can be
written as the sum of two odd prime numbers.

For example:
8 = 3 + 5. Both 3 and 5 are odd prime numbers.
20 = 3 + 17 = 7 + 13.
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.)
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million.

Input

The input will contain one or more test cases.
Each test case consists of one even integer n with 6 <= n < 1000000.
Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

Source

Ulm Local 1998
思路:筛选法弄出素数,然后a从最小素数循环,遇到结果就直接输出。注意C语言比C++速度
#include<stdio.h>
#include<math.h>
#include<string.h>
#define MAXN 1000001
bool vis[MAXN];

int main()
{
    //筛选法挑选素数
    memset(vis,0,sizeof(vis));
    for(int i = 2;i<(int)sqrt((double)MAXN);i++)
    {
        if(!vis[i])
        {
            for(int j=i*i ; j<MAXN;j+=i)
                vis[j]=1;
        }
    }
    int n;
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
            int a = 3;
            for(;a<n;a+=2)
            {
                if(!vis[(n-a)]&&!vis[a])
                {
                    printf("%d = %d + %d\n",n,a,n-a);
                    break;
                }
            }
    }
    return 0;
}

 

快些。
 
posted @ 2014-05-25 00:15  Fighting_frank  阅读(232)  评论(0编辑  收藏  举报