POJ 2586 Y2K Accounting Bug

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. 
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite. 

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612

Deficit

题意:给你每一个月固定的盈利或是亏损的钱,顺序是如何的不知道了,可是能够知道的是。每连续的5个月钱之和必然是亏损的。要你求出最大盈利额。

思路:

首先。d最小的时候假设满足条件那么必然是最大的盈利额。那么怎么来排呢?

对于连续的5个月。为了保证d出现的次数要少。那么前5个月排得时候,尽量把盈利的月放在前面(重点)

所以有4种情况了,具体过程请看代码

AC代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
double sum;
int main()
{
    double s,d;
    while(scanf("%lf %lf",&s,&d)!=EOF)
    {
        sum=0;
        int flag=1;
        if(s>=4*d)
        {
            printf("Deficit\n");
            continue;
        }
        if((4*s>=0)&&(4*s<d)&&flag)
        {
            sum=10*s-2*d;
            flag=0;
        }
        if((3*s<2*d)&&flag)
        {
            sum=8*s-4*d;
            flag=0;
        }
        if(2*s<3*d&&flag)
        {
            sum=6*s-6*d;
            flag=0;
        }
        if(s<4*d&&flag)
        {
            sum=3*s-9*d;
            flag=0;
        }
        if(flag)
        {
            printf("Deficit\n");
            continue;
        }
        if(sum>=0)
            printf("%.lf\n",sum);
        else
             printf("Deficit\n");
    }
    return 0;
}


posted @ 2017-04-22 11:34  jhcelue  阅读(190)  评论(0编辑  收藏  举报