hdu Encoding

Encoding

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 16   Accepted Submission(s) : 13
Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.
 

 

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 

 

Output
For each test case, output the encoded string in a line.
 

 

Sample Input
2 ABC ABBCCC
 

 

Sample Output
ABC A2B3C
 

 

Author
ZHANG Zheng
 
 
#include <stdio.h>
#include <string.h>
int main()
{
	char str[10005];
	int N,i,j=0,k;
	scanf("%d",&N);
	getchar();   //吸收换行符
	while (N--)
	{
		memset(str,0,sizeof(str));
           //	getchar();第一次吸收换行符,后面就吸收第一个字符,错误!
		gets(str);
		int len=0;
		len=strlen(str);
		k=1;
		for (i=0;i<len;i++)
		{
			if (str[i+1]==str[i])//数组开的足够大,并且每次都初始化为0,0和字符值不相等
			{
				k++;	
			}
			else  
			{
				if (k!=1)   printf("%d",k);
				printf("%c",str[i]);
				k=1;        //k的值初始化为1
			}	
		}

		printf("\n");
	}
	return 0;
}

 

posted @ 2013-08-09 22:46  javawebsoa  Views(259)  Comments(0Edit  收藏  举报