省赛热身赛之Javabeans

原题:

Description

Javabeans are delicious. Javaman likes to eat javabeans very much.

Javaman has n boxes of javabeans. There are exactly i javabeans in the i-th box (i = 1, 2, 3,...n). Everyday Javaman chooses an integer x. He also chooses several boxes where the numbers of javabeans are all at least x. Then he eats x javabeans in each box he has just chosen. Javaman wants to eat all the javabeans up as soon as possible.  So how many days it costs for him to eat all the javabeans?

 

Input

 

There are multiple test cases. The first line of input is an integer T ≈ 100 indicating the number of test cases. 

Each test case is a line of a positive integer 0 < n < 231.

 

Output

 

For each test case output the result in a single line.

 

Sample Input

 

 

4
1
2
3
4

 

 

 

 

Sample Output

 

 

1
2
2
3

 

 

 

原码:

#include<stdio.h>
int main()
{
    int n,a,t;
    scanf("%d",&n);
    while(n--)
    {
        a=0;
        scanf("%d",&t);
        while(t)
        {
            a++;
            t=t/2;
        }
        printf("%d\n",a);
    }
    return 0;
}


 

 

posted @ 2013-03-25 18:40  javawebsoa  Views(171)  Comments(0Edit  收藏  举报