代码改变世界

NYOJ 529 月赛水题

2012-04-24 08:19  javaspring  阅读(215)  评论(0编辑  收藏  举报

     这道题可以说是月赛时最水的题了,,没什么意思。题目:

flip

时间限制:1000 ms  |  内存限制:65535 KB
难度:2
描述
Give you a non-negative integer x and an operation. The only operation you can do is to reverse one bit in binary form of x 

once(i.e 1->0, 0->1).
your goal is to turn x into x+1.
Calculate the minimum times of operations you need to do. 
输入
The first line of the input is an integer T indicates the test cases.
Then follow T lines. Each line is a non-negative integer x as described above, note that 0<=x<10^9.
输出
Output the minimum times of operations you need to do to reach the goal.
样例输入
3
1
2
3
样例输出
2
1
3
ac代码:

 
#include <iostream>
#include <stdio.h>
#include <string.h>
int numa[50],numb[50];
void fun(int x,int a[50]){
	int k=0;
	while(x){
	  a[k++]=x%2;
	  x/=2;
	}
}
int main(){
	int numcase,n;
	scanf("%d",&numcase);
	while(numcase--){
	  scanf("%d",&n);
	  memset(numa,0,sizeof(numa));
	  memset(numb,0,sizeof(numb));
	  fun(n,numa);
	  fun(n+1,numb);
	  int s=0;
	  for(int i=0;i<50;++i)
		  if(numa[i]!=numb[i])
			  s++;
	  printf("%d\n",s);
	}
	return 0;
}