代码改变世界

杭电 2844 多重背包(0-1背包二进制处理)

2012-02-22 14:23  javaspring  阅读(276)  评论(0编辑  收藏  举报

        是一道多重背包的题目,因为数据量比较大,所以需要把0-1背包的情况用二进制处理,变成log(n)的复杂度。题目:

Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2339    Accepted Submission(s): 956


Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 

Output
For each test case output the answer on a single line.
 

Sample Input
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 

Sample Output
8 4
 

ac代码:

#include <iostream>
#include <string.h>
#include <cstdio>
using namespace std;
#define max(a,b) a>b?a:b;
struct coin{
  int value,num;
}aa[105];
int dp[100010];
int maxvalue;
void full_bag(int n){
    for(int j=n;j<=maxvalue;++j)
        dp[j]=max(dp[j],dp[j-n]+n);
}
void one_zerobag(int n){
    for(int i=maxvalue;i>=n;--i)
        dp[i]=max(dp[i],dp[i-n]+n);
}
int main(){
  //freopen("1.txt","r",stdin);
  int numcoin;
  while(scanf("%d%d",&numcoin,&maxvalue),numcoin,maxvalue){
    memset(dp,0,sizeof(dp));
    //dp[0]=1;
    for(int i=1;i<=numcoin;++i)
        scanf("%d",&aa[i].value);
    for(int i=1;i<=numcoin;++i)
        scanf("%d",&aa[i].num);
    for(int i=1;i<=numcoin;++i){
        if(aa[i].num*aa[i].value>=maxvalue){
          full_bag(aa[i].value);
         }
        else{
            int k=1;
            while(k<=aa[i].num){
                aa[i].num-=k;
                one_zerobag(k*aa[i].value);
                k<<=1;
            }
            one_zerobag(aa[i].num*aa[i].value);
        }
    }
    int count=0;
    for(int i=1;i<=maxvalue;++i)
        if(dp[i]==i)
        {count++;}
    printf("%d\n",count);
  }
  return 0;
}