代码改变世界

hdu 1394 树状数组求逆序数

2011-10-12 11:09  javaspring  阅读(153)  评论(0编辑  收藏  举报

          以前用过线段树求逆序数,这次想用树状数组试一下,悲催的是想了好久才想明白。。。。看来对树状数组还是不够了解啊。纠结。。。。题目:

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2413    Accepted Submission(s): 1492


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
16
 

ac代码:

#include <iostream>
#include <cstdio>
#include <string.h>
int num[5005];
int total[5005];
int n;
int lowbit(int x){
  return x&(-x);
}
void update(int x){
	while(x>0){
	  total[x]++;
	  x-=lowbit(x);
	}
	//printf("***\n");
}
int add(int x){
	int ss=0;
	x+=1;
	while(x<=n){
	  ss+=total[x];
	  x+=lowbit(x);
	}
	return ss;
}
int main(){
  //int n;
  while(~scanf("%d",&n)){
    memset(num,0,sizeof(num));
	memset(total,0,sizeof(total));
	int sum=0;
	for(int i=0;i<n;++i){
	  scanf("%d",&num[i]);
	  update(num[i]+1);
	  sum+=add(num[i]+1);
	}
	//printf("sum===%d\n",sum);
	int k=0,s=sum;
	for(int i=0;i<n;++i){
	  k=sum-num[i]+(n-1-num[i]);
	  sum=k;
	  //printf("k==%d   s==%d\n",k,s);
	  if(k<s)
		  s=k;
	}
	printf("%d\n",s);
  }
  return 0;
}