代码改变世界

杭电 OJ Color the ball 树状数组

2011-09-28 14:27  javaspring  阅读(230)  评论(0编辑  收藏  举报

         一道简单的树状数组的题,不过用cin和cout   TLE,用printf和scanf  竟然只用了600多ms,这倒是让我意外了。。。题目:

N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
 

Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
 

Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
 

Sample Input
3 1 1 2 2 3 3 3 1 1 1 2 1 3 0
 

Sample Output
1 1 1 3 2 1
 

ac代码:

#include <iostream>
#include <string.h>
#include <string>
#include <cstdio>
int ss[100005];
using namespace std;
int n;
int lowbit(int x){
  return x&(-x);
}
void update(int x,int y){
	while(x>0){
	  ss[x]+=y;
	  x-=lowbit(x);
	}
}
int sum(int x){
  int s=0;
  while(x<=n){
    s+=ss[x];
	x+=lowbit(x);
  }
  return s;
}
int main(){
  //int n;
  while(scanf("%d",&n)&&n){
	  memset(ss,0,sizeof(ss));
    int a,b,m;
	m=n;
	while(m--){
	  scanf("%d%d",&a,&b);
	  update(a-1,-1);
	  update(b,1);
	}
	for(int i=1;i<n;++i){
	  printf("%d ",sum(i));
	 }
	printf("%d\n",sum(n));
  }
  return 0;
}