代码改变世界

NYOJ 413 月赛的悲剧

2011-09-27 15:31  javaspring  阅读(167)  评论(0编辑  收藏  举报

         话说这道题是月赛时的第一题,想这道题至少想了一个半小时,当时的基本思路已经想出来了,就有一个地方一直实现不了,于是就一直在想,悲剧的是,最后还是没能实现。更悲剧的是,最后一个半小时,一次也没提交。。昨天又想了想,还是卡在了那个地方,刚才突然灵光一现,,,,想了出来,,不容易啊。。。。

题目:

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2...Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another. 
For example, the first 80 digits of the sequence are as follows: 
11212312341234512345612345671234567812345678912345678910123456789101112345678910

输入
The first line of the input file contains a single integer t (1 ≤ t ≤ 20), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)
输出
There should be one output line per test case containing the digit located in the position i.
样例输入
2
8
3
样例输出
2
2

ac代码:

#include <iostream>
#include <string.h>
#include <cstdio>
using namespace std;
long long sum[35000],a[35000];
void chushihua(){
  sum[1]=1;a[1]=1;
  for(int i=2;i<=9;++i){
    sum[i]=sum[i-1]+a[1]+(i-1);
	a[i]=sum[i]-sum[i-1];
  }
  for(int i=10;i<=99;++i){
    sum[i]=sum[i-1]+a[9]+(i-9)*2;
	a[i]=sum[i]-sum[i-1];
  }
  for(int i=100;i<=999;++i){
    sum[i]=sum[i-1]+a[99]+(i-99)*3;
	a[i]=sum[i]-sum[i-1];
  }
  for(int i=1000;i<=9999;++i){
    sum[i]=sum[i-1]+a[999]+(i-999)*4;
	a[i]=sum[i]-sum[i-1];
  }
  for(int i=10000;i<=34999;++i){
    sum[i]=sum[i-1]+a[9999]+(i-9999)*5;
	a[i]=sum[i]-sum[i-1];
  }
}
int main(){
  int k;
  chushihua();
  scanf("%d",&k);
  while(k--){
    long long n;
	cin>>n;
	long long kk;
	for(int i=1;i<=34999;++i){
	  if(sum[i]<n&&sum[i+1]>=n)
	  {
		kk=i;break;
	  }
	}
	n-=sum[kk];
    int x=1;
	for(int i=0;i<34999;++i){
	  if(a[i]<n&&a[i+1]>=n)
	  {x=i;break;}
	}
	n-=a[x];
	x++;
	int b[11],zz=1;
	while(x){
	  b[zz++]=x%10;
	  x/=10;
	}
	cout<<b[zz-n]<<endl;
  }
  return 0;
}