代码改变世界

数论之求欧拉函数

2011-09-24 09:10  javaspring  阅读(213)  评论(0编辑  收藏  举报

        简单的求欧拉函数的值,留下来做个模板。。。。。。。。。。

题目:

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.
 

Input
There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.
 

Output
For each test case there should be single line of output answering the question posed above.
 

Sample Input
7 12 0
 

Sample Output
6 4
 
ac代码:

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
long long euler(long long y){
  int m=(int)sqrt(y+0.5);
  int ans=y;
  for(int i=2;i<=m;++i){
	  if(y%i==0){
	    ans=ans/i*(i-1);
		while(y%i==0)
			y/=i;
	  }
  }
  if(y>1)
	  ans=ans/y*(y-1);
  return ans;
}
int main()
{
  long long n;
  while(cin>>n&&n){
    long long x=euler(n);
	cout<<x<<endl;
  }
}