POJ2386:Lake Counting(DFS)

Lake Counting
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14776   Accepted: 7496

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

Source

 

MYCode:

#include<iostream>
#include<cstring>
#include<cstdio>
#define MAX 110
char map[MAX][MAX];
bool vis[MAX][MAX];
int dirt[8][2]={{1,0},{-1,0},{0,1},{0,-1},{1,1},{1,-1},{-1,1},{-1,-1}};
using namespace std;
void dfs(int x,int y)
{
    vis[x][y]=1;
    int i;
    int tx,ty;
    for(i=0;i<8;i++)
    {
        tx=x+dirt[i][0];
        ty=y+dirt[i][1];
        if(!vis[tx][ty] && map[tx][ty]=='W')
        {
            dfs(tx,ty);
        }
    }
}

int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        int i,j;
        memset(vis,0,sizeof(vis));
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=m;j++)
            {
                cin>>map[i][j];
            }
        }
        int ans=0;
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=m;j++)
            {
                if(map[i][j]=='W'&&!vis[i][j])
                {
                    ans++;
                    dfs(i,j);
                }
            }
        }
        printf("%d\n",ans);
    }
}

//

DFS

posted @ 2012-11-27 14:13  java程序员-c  阅读(152)  评论(0编辑  收藏  举报