木其网络科技专业程序员代写http://www.xmsydw.com
程序员学历擅长经验网店链接
apenny硕士ASP.NET PHP 电子 通信设计 图像 编程 网络5年进入店铺
zheng_qianqian本科C语言 C++面向对象 Java5年进入店铺
guoguanl本科Java Web项目 JSP Hibernate Struts Mysql5年进入店铺

POJ 2418 Hardwood Species 二叉排序树

Hardwood Species
Time Limit: 10000MS   Memory Limit: 65536K
Total Submissions: 15011   Accepted: 6042

Description

Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter. 
America's temperate climates produce forests with hundreds of hardwood species -- trees that share certain biological characteristics. Although oak, maple and cherry all are types of hardwood trees, for example, they are different species. Together, all the hardwood species represent 40 percent of the trees in the United States. 

On the other hand, softwoods, or conifers, from the Latin word meaning "cone-bearing," have needles. Widely available US softwoods include cedar, fir, hemlock, pine, redwood, spruce and cypress. In a home, the softwoods are used primarily as structural lumber such as 2x4s and 2x6s, with some limited decorative applications. 

Using satellite imaging technology, the Department of Natural Resources has compiled an inventory of every tree standing on a particular day. You are to compute the total fraction of the tree population represented by each species.

Input

Input to your program consists of a list of the species of every tree observed by the satellite; one tree per line. No species name exceeds 30 characters. There are no more than 10,000 species and no more than 1,000,000 trees.

Output

Print the name of each species represented in the population, in alphabetical order, followed by the percentage of the population it represents, to 4 decimal places.

Sample Input

Red Alder
Ash
Aspen
Basswood
Ash
Beech
Yellow Birch
Ash
Cherry
Cottonwood
Ash
Cypress
Red Elm
Gum
Hackberry
White Oak
Hickory
Pecan
Hard Maple
White Oak
Soft Maple
Red Oak
Red Oak
White Oak
Poplan
Sassafras
Sycamore
Black Walnut
Willow

Sample Output

Ash 13.7931
Aspen 3.4483
Basswood 3.4483
Beech 3.4483
Black Walnut 3.4483
Cherry 3.4483
Cottonwood 3.4483
Cypress 3.4483
Gum 3.4483
Hackberry 3.4483
Hard Maple 3.4483
Hickory 3.4483
Pecan 3.4483
Poplan 3.4483
Red Alder 3.4483
Red Elm 3.4483
Red Oak 6.8966
Sassafras 3.4483
Soft Maple 3.4483
Sycamore 3.4483
White Oak 10.3448
Willow 3.4483
Yellow Birch 3.4483

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceeded.



二叉排序树,和其他正常一样,左大右小,排完中序输出就可以了。。。

本来还考虑用sort排序,然后计算下数就行了,可是题目说10000结点1000000树,果断会超时,即使题目给10s也不够啊。。。

果断要用二叉树,在建树时还能计算出现次数。。。

Accepted 564K 1469MS G++ 954B

AC代码:

#include<cstdio>
#include<cstring>
#include<cstdlib>
#define MAXN 40

typedef struct TNode{
	char name[MAXN];
	struct TNode *l, *r;
	int cnt;
}Node;
int sum = 0;

Node* newnd(char *ch)
{
	Node *u = (Node*) malloc(sizeof(Node));
	if (u != NULL)
	{
		strcpy(u->name, ch);
		u->r = u->l = NULL;
		u->cnt = 1;
		sum++;
	}
	return u;
}

Node* addnd(Node *nd, char *ch)
{
	if (nd == NULL)
		nd = newnd(ch);
	else
	{
		int cmp = strcmp(nd->name, ch);
		if (cmp == 0)
		{
			nd->cnt++;
			sum++;
		}
		else if (cmp > 0)
			nd->r = addnd(nd->r, ch);
		else
			nd->l = addnd(nd->l, ch);
	}
	return nd;
}

void Inorder(Node* root)
{
	if (root != NULL)
	{
		Inorder(root->r);
		printf("%s %.4f\n", root->name, 100*(double)root->cnt/(double)sum);
		Inorder(root->l);
	}
}

int main()
{
	char ch[MAXN];
	Node* root = NULL;
	while (gets(ch) != NULL)
		root = addnd(root, ch);
	Inorder(root);
	return 0;
}


posted @ 2013-04-25 11:05  程序流程图  阅读(368)  评论(0编辑  收藏  举报
木其网络科技专业程序员代写http://www.xmsydw.com
程序员学历擅长经验网店链接
apenny硕士ASP.NET PHP 电子 通信设计 图像 编程 网络5年进入店铺
zheng_qianqian本科C语言 C++面向对象 Java5年进入店铺
guoguanl本科Java Web项目 JSP Hibernate Struts Mysql5年进入店铺