Digital Roots(c递归求解)

前言

今天晚上现在是12:38写了个递归程序解决了九度的一个二星题,自我感觉写的还不错,记录一下。解题思路:
  • 看懂英语,因为是英文描述的
  • 大整数的时候尽量用字符串存储,普通的就算是long long int类型一般都不够九度测试的长度(我就因为开始用了intWA了一次)

题目描述:

    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

输入:

    The input file will contain a list of positive integers, one per line. 
    The end of the input will be indicated by an integer value of zero.

输出:

    For each integer in the input, output its digital root on a separate line of the output.

样例输入:

24
39
0

样例输出:

6
3

提示:

The integer may consist of a large number of digits.

AC代码(递归求解)

#include <stdio.h>
#include <stdlib.h>
#include <string.h>


char* digitsRoot(char *);

int main()
{
	char str[1000];
	char *root;

	while(scanf("%s", str) != EOF && str[0] != '0')
	{
		root = digitsRoot(str);
		printf("%d\n",root[0] - '0');
	}

	return 0;
}

/**
 * Description:递归的求root
 */
char* digitsRoot(char *str)
{
	int len, i, count, j;
	char recursive[1000];

	len = strlen(str);	
	//递归终止条件
	if(len == 1)
	{
		return str;
	}

	for(i = 0, count = 0; i < len; i ++)
	{
		count += str[i] - '0';
	}


	memset(recursive, '\0', sizeof(recursive));
	for(j = 0; count; j ++)
	{
		recursive[j] = (count % 10) + '0';
		count /= 10;
	}
	
	digitsRoot(recursive);
}

后记

现在感觉自己发的博客还是很水的,慢慢积累吧,大学的时候都不懂递归,现在能在脑海里有思路用在代码里还是不错的,加油!!
posted @ 2012-12-08 00:38  java程序员填空  阅读(193)  评论(0编辑  收藏  举报