代码改变世界

poj 2386 Lake Counting-----DFS

2012-05-16 20:28  java环境变量  阅读(272)  评论(0编辑  收藏  举报

Lake Counting
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13556   Accepted: 6909

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

            

        DFS入门级题目。 求有多少片W的区域,示例已经很清楚。

代码:
//Memory: 492 KB		Time: 0 MS
//Language: C++		Result: Accepted


#include<stdio.h>
#include<string.h>
int vir[105][105],h,w;
char map[105][105];
void dfs(int x,int y);
int dir[8][2]={{1,1},{1,0},{1,-1},{0,1},{0,-1},{-1,1},{-1,0},{-1,-1}};
int main()
{
//	freopen("in.txt","r",stdin);
	while(scanf("%d%d",&h,&w)!=EOF)
	{
		int count=0,i,j;
		memset(vir,0,sizeof(vir));
		getchar();
		for(i=0;i<h;i++)
			gets(map[i]);
		for(i=0;i<h;i++)
			for(j=0;j<w;j++)
				if(map[i][j]=='W'&&!vir[i][j])
				{
					vir[i][j]=1;
					dfs(i,j);
					count++;
				}
		printf("%d\n",count);
	}
	return 0;
}
void dfs(int x,int y)
{
	int i;
	for(i=0;i<8;i++)
	{
		int dx=x+dir[i][0], dy=y+dir[i][1];
		if(dx>=0 && dx<h && dy>=0 && dy<w && !vir[dx][dy] && map[x][y]=='W')
		{
			vir[dx][dy]=1;	
			dfs(dx,dy);
		}
	}
}