代码改变世界

poj 1269 Intersecting Lines -----计算几何

2012-04-19 20:05  java环境变量  阅读(290)  评论(0编辑  收藏  举报

Intersecting Lines
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 6451   Accepted: 3023

Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect. 
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000. 

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".

Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

题目大意: 输入四个点a,b,c,d.   ab构成一条直线。  cd构成一条直线。   判断 ab和 cd  的位置关系。   平行输出 NONE,    重合输出  LINE , 有交点 求出交点。

解题 思路:   向量的叉积。    主要是求交点,  用有向面积  的比值  求出 点坐标 的比。。  。。  虽然这些肯定有模板,自己写出来的还是感觉好多了。,。哈哈。


一次AC的代码,代码有点长。  没简化。

#include<stdio.h>
#include<math.h>
const double PRE = 10e-8;     //这里注意,不能用 ==0  判断 叉积等于0.  计算机的精度误差。
struct point 
{
	double x,y;
}p[4],result,v[3];
int main()
{
	//freopen("in.txt","r",stdin);
	int n,i;
	int noneJudge(point a,point b, point c, point d);    //判断 不相交。
	int lineJudge(point a,point c,point d);            //判断 重合
	void crossPoint(point a,point b, point c, point d);         //求交点
	while(scanf("%d",&n)!=EOF)
	{
		printf("INTERSECTING LINES OUTPUT\n");
		while(n--)
		{
			for(i=0;i<4;i++)
				scanf("%lf%lf", &p[i].x, &p[i].y);
			if(noneJudge(p[0], p[1], p[2], p[3]))
			{
				if(lineJudge(p[0], p[2], p[3]))
					printf("LINE\n");
				else printf("NONE\n");
			}
			else
			{
				crossPoint(p[0], p[1], p[2], p[3]);
				printf("POINT %.2lf %.2lf\n", result.x, result.y);
			}
		}
		printf("END OF OUTPUT\n");
	}
	return 0;
}

int noneJudge(point a,point b, point c,point d)
{
	v[0].x=b.x-a.x;
	v[0].y=b.y-a.y;
	v[1].x=d.x-c.x;
	v[1].y=d.y-c.y;
	if( fabs(v[0].x*v[1].y-v[0].y*v[1].x) <=PRE)   
		return 1;
	return 0;
}

int lineJudge(point a,point c,point d)
{
	v[0].x=c.x-a.x;
	v[0].y=c.y-a.y;
	v[1].x=d.x-a.x;
	v[1].y=d.y-a.y;
	if( fabs(v[0].x*v[1].y-v[0].y*v[1].x) <= PRE)
		return 1;
	return 0;
}

void crossPoint(point a,point b, point c, point d)
{
	double area1,area2;
	v[0].x=b.x-a.x;
	v[0].y=b.y-a.y;
	v[1].x=c.x-a.x;
	v[1].y=c.y-a.y;
	v[2].x=d.x-a.x;
	v[2].y=d.y-a.y;
	area1 = v[0].x * v[1].y - v[0].y * v[1].x;      //有向面积很方便 , 可以不用考虑点的绝对坐标位置。
	area2 = v[0].x * v[2].y - v[0].y * v[2].x ;     //因为有向面积是相对位置而言的。
	result.x = (area2 * c.x - area1 * d.x)/(area2-area1);
	result.y = (area2 * c.y - area1 * d.y)/(area2-area1);
}