代码改变世界

poj 3122 Pie--- 二分

2012-03-13 17:21  java环境变量  阅读(207)  评论(0编辑  收藏  举报

Pie
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6264   Accepted: 2353   Special Judge

Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10−3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655


        这是二分的第一题。  刚开始题目意思有点纠结,所以参考了别人的结题报告。

     题目大意:  几个朋友 和自己 来分 pie。 有 n个 pie,输入 半径,高度是1。 求每个人能分到的最多的体积。每个人分的必须是完整了,不能两部分拼起来。  

//Memory: 212 KB		Time: 32 MS
//Language: C++		Result: Accepted
#include<stdio.h>
#include<math.h>
const double PI = acos(-1.0);
int main()
{
	//freopen("1.txt","r",stdin);
	int t,n,f,i,j;
	double p[10010],sum,r;
	scanf("%d",&t);
	while(t--)
	{
		sum=0;
		scanf("%d%d",&n,&f);
		f++;
		for(i=0;i<n;i++)
		{
			scanf("%lf",&r);
			p[i]=r*r;
			sum+=p[i]; 
		}
		double max,min,mid;
		max=sum/f;
		min=0;
		while(max-min>1e-5)
		{
			int num=0;
			mid=(max+min)/2;
			for(i=0;i<n;i++)
				num+=int (p[i]/mid);   //这里的p[i]是学别人的。就一些细节。如果用r*r而不是p[i],运算次数会增加
			if(num>=f) min=mid;
			else max=mid;
		}
		printf("%.4lf\n",mid*PI);
	}
	return 0;
}