代码改变世界

hdu_1009 FatMouse' Trade----贪心

2012-02-03 01:55  java环境变量  阅读(168)  评论(0编辑  收藏  举报
 

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20004    Accepted Submission(s): 6223


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 
Sample Output
13.333 31.500
 
 
 
 
           还是一道贪心算法的题。刚接触贪心,所以趁热打铁继续做几道题。有点晚了 有点累 。
          这道题 的思路是,总是先选得到与付出比最大的。
                   
 
#include<stdio.h>
int main()
{
	//freopen("1.in","r",stdin);
	void swap(double *,double *);  //声明了一个交换函数用于排序。顺便回顾了一下用指针改变数组的值。
	int m,n,i,j;
	double ave[1000],get[1000],pay[1000],sum;
	while(scanf("%d%d",&m,&n)!=EOF&&(m!=-1||n!=-1))
	{
		sum=0;
		for(i=0;i<n;i++)
		{	
			scanf("%lf%lf",&get[i],&pay[i]);
			ave[i]=get[i]/pay[i];         //计算得到付出之比。
		}
             //下面是按得到付出之比 从大到小排好序。
 	    for(i=1;i<n;i++)
			for(j=0;j<n-i;j++)
			{
				if(ave[j]<ave[j+1])
				{
				      swap(ave+j,ave+j+1);
                                          swap(get+j,get+j+1);
				       swap(pay+j,pay+j+1);
				}
			}
              //计算能得到的最大值。
		for(i=0;i<n;i++)
		{
			if(m>=pay[i])
                                    sum+=get[i];
			else
			{
				sum+=ave[i]*m;
				break;
			}
			m-=(int)pay[i];
		}
		printf("%.3lf\n",sum);
	}
	return 0;
}
void swap(double *a,double *b)
{
	double t;
    t=* a;
	* a=* b;
	* b=t;
}