HDU_1542_(树状数组)

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9435    Accepted Submission(s): 3779


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
 

 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

 

Sample Input
5
1 1
5 1
7 1
3 3
5 5
 

 

Sample Output
1
2
1
1
0

题意:一颗star,它左下方、左边、下边的star数和为它的等级,问1-->n-1级的star各有多少颗。
 
开始以为是二维的树状数组,发现开不了那么大的数组,然后发现,输入是按y坐标升序排列的,那么就是最基本的树状数组了。
 
坑点:x坐标可以为0。。。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define N 32005

int s[N];
int lowbit(int x)
{
    return x&(-x);
}

void add(int x,int num)
{
    while(x<=N)
    {
        s[x]+=num;
        x+=lowbit(x);
    }
}

int sum(int x)
{
    int res=0;
    while(x>0)
    {
        res+=s[x];
        x-=lowbit(x);
    }
    return res;
}

int level[N>>1];

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(s,0,sizeof(s));
        memset(level,0,sizeof(level));
        for(int i=0; i<n; i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            level[sum(x+1)]++;
            add(x+1,1);
        }
        for(int i=0; i<=n-1; i++)
            printf("%d\n",level[i]);
    }
    return 0;
}

 

posted on 2017-03-24 22:00  JASONlee3  阅读(159)  评论(0编辑  收藏  举报

导航