POJ_3013_最短路

Big Christmas Tree
Time Limit: 3000MS   Memory Limit: 131072K
Total Submissions: 23630   Accepted: 5125

Description

Christmas is coming to KCM city. Suby the loyal civilian in KCM city is preparing a big neat Christmas tree. The simple structure of the tree is shown in right picture.

The tree can be represented as a collection of numbered nodes and some edges. The nodes are numbered 1 through n. The root is always numbered 1. Every node in the tree has its weight. The weights can be different from each other. Also the shape of every available edge between two nodes is different, so the unit price of each edge is different. Because of a technical difficulty, price of an edge will be (sum of weights of all descendant nodes) × (unit price of the edge).

Suby wants to minimize the cost of whole tree among all possible choices. Also he wants to use all nodes because he wants a large tree. So he decided to ask you for helping solve this task by find the minimum cost.

Input

The input consists of T test cases. The number of test cases T is given in the first line of the input file. Each test case consists of several lines. Two numbers ve (0 ≤ ve ≤ 50000) are given in the first line of each test case. On the next line, v positive integers wi indicating the weights of v nodes are given in one line. On the following e lines, each line contain three positive integers abc indicating the edge which is able to connect two nodes a and b, and unit price c.

All numbers in input are less than 216.

Output

For each test case, output an integer indicating the minimum possible cost for the tree in one line. If there is no way to build a Christmas tree, print “No Answer” in one line.

Sample Input

2
2 1
1 1
1 2 15
7 7
200 10 20 30 40 50 60
1 2 1
2 3 3
2 4 2
3 5 4
3 7 2
3 6 3
1 5 9

Sample Output

15
1210

题意:给一张点和边都有权的图,现在要求其一棵以1结点为根的生成树使树的边权和最小,树边权 = 对应的图边权 * 树边末端点为根的子树所有结点对于图顶点的点权和。

  思路:要求∑(边权*子树点权和),等价于求∑(点权*点到根路径上的边权和)。

第一道SPFA。

 

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
#define N 50005
#define LL long long
#define INF (1LL<<60)

struct Edge
{
    int v,next;
    LL w;
} edge[N];

int head[N];

int cnte=0;
void addEdge(int a,int b,int w)
{
    edge[cnte].v=b;
    edge[cnte].w=w;
    edge[cnte].next=head[a];
    head[a]=cnte++;
}

LL dist[N];
bool vis[N];
bool Spfa(int n)
{
    for(int i=1; i<=n; i++)
    {
        dist[i]=INF;
        vis[i]=0;
    }
    dist[1]=0;
    vis[1]=1;
    queue<int>q;
    q.push(1);
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        for(int i=head[u]; i!=-1; i=edge[i].next)
        {
            int v=edge[i].v;
            if(dist[v]>dist[u]+edge[i].w)
            {
                dist[v]=dist[u]+edge[i].w;
                if(vis[v]==0)
                {
                    vis[v]=1;
                    q.push(v);
                }
            }
        }
        vis[u]=0;
    }
    for(int i=1; i<=n; i++)
    {
        if(dist[i]==INF)
            return 0;
    }
    return 1;
}

int verw[N];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        cnte=0;
        int vn,en;
        scanf("%d%d",&vn,&en);
        for(int i=1; i<=vn; i++)
            scanf("%d",verw+i);
        memset(head,-1,sizeof(head));
        for(int i=0; i<en; i++)
        {
            int a,b,w;
            scanf("%d%d%d",&a,&b,&w);
            addEdge(a,b,w);
            addEdge(b,a,w);
        }
        if(!Spfa(vn))
        {
            puts("No Answer");
            continue;
        }
        else
        {
            LL res=0;
            for(int i=1; i<=vn; i++)
                res+=verw[i]*dist[i];
            printf("%lld\n",res);
        }
    }
    return 0;
}

 


posted on 2016-11-28 22:43  JASONlee3  阅读(953)  评论(0编辑  收藏  举报

导航