HDU_1729_sg函数(dfs)

Stone Game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 3051    Accepted Submission(s): 939


Problem Description
This game is a two-player game and is played as follows:

1. There are n boxes; each box has its size. The box can hold up to s stones if the size is s.
2. At the beginning of the game, there are some stones in these boxes.
3. The players take turns choosing a box and put a number of stones into the box. The number mustn’t be great than the square of the number of stones before the player adds the stones. For example, the player can add 1 to 9 stones if there are 3 stones in the box. Of course, the total number of stones mustn’t be great than the size of the box.
4.Who can’t add stones any more will loss the game.

Give an Initial state of the game. You are supposed to find whether the first player will win the game if both of the players make the best strategy.
 

 

Input
The input file contains several test cases.
Each test case begins with an integer N, 0 < N ≤ 50, the number of the boxes.
In the next N line there are two integer si, ci (0 ≤ ci ≤ si ≤ 1,000,000) on each line, as the size of the box is si and there are ci stones in the box.
N = 0 indicates the end of input and should not be processed.
 

 

Output
For each test case, output the number of the case on the first line, then output “Yes” (without quotes) on the next line if the first player can win the game, otherwise output “No”.
 

 

Sample Input
3
2 0
3 3
6 2
2
6 3
6 3
0
 

 

Sample Output
Case 1: Yes
Case 2: No
 
题意:n个盒子,每个容量为si,已装入ci个石子,两个玩家,分别往盒子中放入石子,每次放入的石子数量不能超过盒子中石子数量的平方,没有盒子可以放的玩家败。
最开始想用之前的模版来做,求sg值,但是这道题的“点数”为1000000,用之前的模版显然超时,所以果断看了题解,大牛们用的是dfs求每个点的sg值。
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
using namespace std;
#define N 1000005

int Sg(int c,int s)
{
    int t=sqrt(s);
    while(t*t+t>=s)
        t--;
    if(c>t)
        return s-c;
    else
        return Sg(c,t);
}

int main()
{
    int n,cnt=0;
    while(scanf("%d",&n)!=EOF&&n)
    {
        int s,c,res=0;
        while(n--)
        {
            scanf("%d%d",&s,&c);
            res^=Sg(c,s);
        }
        printf("Case %d:\n",++cnt);
        if(res)
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}

 

posted on 2016-07-25 14:24  JASONlee3  阅读(319)  评论(0编辑  收藏  举报

导航