PAT 1006. Sign In and Sign Out (25)

1006. Sign In and Sign Out (25)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133
#include <iostream>
#include <string>

using namespace std;

class Record
{
private:
	string id;
	string sign_in;
	string sign_out;
public:
	friend istream& operator>>(istream& is, Record& item);
	friend bool cmp_in(Record& lhs, Record& rhs);
	friend bool cmp_out(Record& lhs, Record& rhs);
	string GetId(){ return id; }
	string GetIn(){ return sign_in; }
	string GetOut(){ return sign_out; }
};

istream& operator>>(istream& is, Record& item)
{
	is >> item.id >> item.sign_in >> item.sign_out;

	return is;
}

bool cmp_in(Record& lhs, Record& rhs)
{
	return lhs.sign_in > rhs.sign_in;
}

bool cmp_out(Record& lhs, Record& rhs)
{
	return lhs.sign_out > rhs.sign_out;
}

int main()
{
	Record min_in, max_out, tmp;
	string id_in, id_out;
	int recordNum;

	cin >> recordNum;
	cin >> tmp;
	min_in = max_out = tmp;
	id_in = tmp.GetId();
	id_out = tmp.GetId();

	while (--recordNum)
	{
		cin >> tmp;
		if (cmp_in(min_in, tmp))
		{
			min_in = tmp;
			id_in = tmp.GetId();
		}
		if (cmp_out(tmp, max_out))
		{
			max_out = tmp;
			id_out = tmp.GetId();
		}
	}

	cout << id_in << " " << id_out;
}
posted @ 2015-08-03 19:01  JackWang822  阅读(195)  评论(0编辑  收藏  举报