POJ 3177 Redundant Paths (双连通)

Redundant Paths
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6982   Accepted: 3042

Description

In order to get from one of the F (1 <= F <= 5,000) grazing fields (which are numbered 1..F) to another field, Bessie and the rest of the herd are forced to cross near the Tree of Rotten Apples. The cows are now tired of often being forced to take a particular path and want to build some new paths so that they will always have a choice of at least two separate routes between any pair of fields. They currently have at least one route between each pair of fields and want to have at least two. Of course, they can only travel on Official Paths when they move from one field to another. 

Given a description of the current set of R (F-1 <= R <= 10,000) paths that each connect exactly two different fields, determine the minimum number of new paths (each of which connects exactly two fields) that must be built so that there are at least two separate routes between any pair of fields. Routes are considered separate if they use none of the same paths, even if they visit the same intermediate field along the way. 

There might already be more than one paths between the same pair of fields, and you may also build a new path that connects the same fields as some other path.

Input

Line 1: Two space-separated integers: F and R 

Lines 2..R+1: Each line contains two space-separated integers which are the fields at the endpoints of some path.

Output

Line 1: A single integer that is the number of new paths that must be built.

Sample Input

7 7
1 2
2 3
3 4
2 5
4 5
5 6
5 7

Sample Output

2

Hint

Explanation of the sample: 

One visualization of the paths is: 
   1   2   3
+---+---+
| |
| |
6 +---+---+ 4
/ 5
/
/
7 +
Building new paths from 1 to 6 and from 4 to 7 satisfies the conditions. 
   1   2   3
+---+---+
: | |
: | |
6 +---+---+ 4
/ 5 :
/ :
/ :
7 + - - - -
Check some of the routes: 
1 – 2: 1 –> 2 and 1 –> 6 –> 5 –> 2 
1 – 4: 1 –> 2 –> 3 –> 4 and 1 –> 6 –> 5 –> 4 
3 – 7: 3 –> 4 –> 7 and 3 –> 2 –> 5 –> 7
 
Every pair of fields is, in fact, connected by two routes. 

It's possible that adding some other path will also solve the problem (like one from 6 to 7). Adding two paths, however, is the minimum.

Source

 
 
题意:有F个农场 有R条路把它们相连(当然是无向的) 要求加多少条边,使得每两个农场之间起码有两条不同的路径

思路:求无向图的边双连通 缩点后,求出叶子结点的个数 加1 除2 就是要加的边 (这是个定理,这里就不证明了)
 
#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int VM=5010;
const int EM=10010;

struct Edge{
    int to,nxt;
}edge[EM<<1];

int head[VM],vis[VM],dfn[VM],low[VM];
int n,k,cnt;

void addedge(int cu,int cv){
    edge[cnt].to=cv;
    edge[cnt].nxt=head[cu];
    head[cu]=cnt++;
}

void Tarjan(int u,int fa){
    vis[u]=1;
    dfn[u]=low[u]=++k;
    for(int i=head[u];i!=-1;i=edge[i].nxt){
        int v=edge[i].to;
        if(vis[v]==1 && v!=fa)
            low[u]=min(low[u],dfn[v]);
        if(!vis[v]){
            Tarjan(v,u);
            low[u]=min(low[u],low[v]);
        }
    }
    vis[u]=2;
}

int main(){

    //freopen("input.txt","r",stdin);

    int m;
    int deg[VM];
    while(~scanf("%d%d",&n,&m)){
        memset(head,-1,sizeof(head));
        memset(vis,0,sizeof(vis));
        memset(dfn,0,sizeof(dfn));
        memset(low,0,sizeof(low));
        memset(deg,0,sizeof(deg));
        cnt=0;
        int u,v;
        while(m--){
            scanf("%d%d",&u,&v);
            if(head[u]!=-1 && edge[head[u]].to==v)  //注意有重边,加判断去掉重边
                continue;
            addedge(u,v);
            addedge(v,u);
        }
        k=0;
        Tarjan(1,1);
        for(u=1;u<=n;u++)
            for(int i=head[u];i!=-1;i=edge[i].nxt){
                v=edge[i].to;
                if(low[u]!=low[v])
                    deg[low[u]]++;  //算出缩点后每个点的度
            }
        int left=0;
        for(int i=1;i<=n;i++)
            if(deg[i]==1)   //度为1 的为叶子结点
                left++;
        printf("%d\n",(left+1)>>1);
    }
    return 0;
}

 

posted @ 2013-05-01 22:21  Jack Ge  阅读(470)  评论(0编辑  收藏  举报