HDU 连连看

连连看

Time Limit : 20000/10000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 109   Accepted Submission(s) : 33

Font: Times New Roman | Verdana | Georgia

Font Size:  

Problem Description

“连连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来(这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见,连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。
玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。

Input

输入数据有多组。每组数据的第一行有两个正整数n,m(0<n<=1000,0<m<1000),分别表示棋盘的行数与列数。在接下来的n行中,每行有m个非负整数描述棋盘的方格分布。0表示这个位置没有棋子,正整数表示棋子的类型。接下来的一行是一个正整数q(0<q<50),表示下面有q次询问。在接下来的q行里,每行有四个正整数x1,y1,x2,y2,表示询问第x1行y1列的棋子与第x2行y2列的棋子能不能消去。n=0,m=0时,输入结束。
注意:询问之间无先后关系,都是针对当前状态的!

Output

每一组输入数据对应一行输出。如果能消去则输出"YES",不能则输出"NO"。

Sample Input

3 4
1 2 3 4
0 0 0 0
4 3 2 1
4
1 1 3 4
1 1 2 4
1 1 3 3
2 1 2 4
3 4
0 1 4 3
0 2 4 1
0 0 0 0
2
1 1 2 4
1 3 2 3
0 0

Sample Output

YES
NO
NO
NO
NO
YES

Author

lwg

 

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>

using namespace std;

const int INF=0x3f3f3f3f;
const int N=1010;

int n,m;
int map[N][N],vis[N][N];

struct node{
    int x,y;
    int aim,corner;
}s,t;

int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
//int dir[4][2]={{-1,0},{1,0},{0,-1},{0,1}}; 改成这样就WA了,纳闷ing

void BFS(){
    queue<node> q;
    while(!q.empty())
        q.pop();
    s.aim=-1;s.corner=0;
    q.push(s);
    node cur,next;
    while(!q.empty()){
        cur=q.front();
        q.pop();
        if(cur.x==t.x && cur.y==t.y){
            printf("YES\n");
            return ;
        }
        for(int i=0;i<4;i++){
            next.x=cur.x+dir[i][0];
            next.y=cur.y+dir[i][1];
            next.aim=i;
            next.corner=cur.corner;
            if(cur.aim!=-1 && next.aim!=cur.aim)
                next.corner++;
            if(next.x<1 || next.x>n || next.y<1 || next.y>m || next.corner>2)
                continue;
            if(map[next.x][next.y] && !(next.x==t.x && next.y==t.y))
                continue;
            if(next.corner<vis[next.x][next.y]){
                vis[next.x][next.y]=next.corner;
                q.push(next);
            }
        }
    }
    printf("NO\n");
}

int main(){

    //freopen("input.txt","r",stdin);

    while(~scanf("%d%d",&n,&m)){
        if(n==0 && m==0)
            break;
        int i,j;
        for(i=1;i<=n;i++)
            for(j=1;j<=m;j++)
                scanf("%d",&map[i][j]);
        int q;
        scanf("%d",&q);
        while(q--){
            scanf("%d%d%d%d",&s.x,&s.y,&t.x,&t.y);
            if(s.x==t.x && s.y==t.y){
                printf("NO\n");
                continue;
            }
            if(!map[s.x][s.y] || !map[t.x][t.y] || (map[s.x][s.y]!=map[t.x][t.y])){
                printf("NO\n");
                continue;
            }
            for(i=1;i<=n;i++)
                for(j=1;j<=m;j++)
                    vis[i][j]=INF;
            BFS();
        }
    }
    return 0;
}

 

posted @ 2013-04-28 12:27  Jack Ge  阅读(353)  评论(0编辑  收藏  举报