HDU 4300 Clairewd’s message (KMP)

Clairewd’s message

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 16   Accepted Submission(s) : 7
Problem Description
Clairewd is a member of FBI. After several years concealing in BUPT, she intercepted some important messages and she was preparing for sending it to ykwd. They had agreed that each letter of these messages would be transfered to another one according to a conversion table.
Unfortunately, GFW(someone's name, not what you just think about) has detected their action. He also got their conversion table by some unknown methods before. Clairewd was so clever and vigilant that when she realized that somebody was monitoring their action, she just stopped transmitting messages.
But GFW knows that Clairewd would always firstly send the ciphertext and then plaintext(Note that they won't overlap each other). But he doesn't know how to separate the text because he has no idea about the whole message. However, he thinks that recovering the shortest possible text is not a hard task for you.
Now GFW will give you the intercepted text and the conversion table. You should help him work out this problem.
 

 

Input
The first line contains only one integer T, which is the number of test cases.
Each test case contains two lines. The first line of each test case is the conversion table S. S[i] is the ith latin letter's cryptographic letter. The second line is the intercepted text which has n letters that you should recover. It is possible that the text is complete.
Hint
Range of test data:
T<= 100 ;
n<= 100000;
 

 

Output
For each test case, output one line contains the shorest possible complete text.
 

 

Sample Input
2
abcdefghijklmnopqrstuvwxyz
abcdab
qwertyuiopasdfghjklzxcvbnm
qwertabcde
 

 

Sample Output
abcdabcd
qwertabcde
 

 

Source
2012 Multi-University Training Contest 1
 
 题意为:给定一个翻译表,即第i个字母用那个字母表示  ,再给一个串,里面前面为密文,后面为明文,密文一定是完整的,但明文不完整或可能没有, 求这个完整的前面密文后面明文的串 
 
把给定的串全部按表翻译为密文,这样例如
样例    qwertabcde 
翻译: jvtkzqwert
 
可发现翻译后的后半部分与原传相同,把原串作为T串,翻译后的为S串,求B 题目要求求最短长度, 从B的一半开始, 当找到第一个满足 B[i]== len- i条件的,i即为第一个明文的位置 

 

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int N=100010;

char text[30],s1[N],s2[N];
int next[N];

void getnext(char t[]){
    int i=0,j=-1;
    int len=strlen(t);
    next[0]=-1;
    while(i<len){
        if(j==-1 || t[i]==t[j]){
            i++;j++;
            next[i]=j;
        }else
            j=next[j];
    }
}

int KMP(char *s,char *t){   
    int i=0,j=0;
    int slen=strlen(s),tlen=strlen(t);
    getnext(t);
    while(i<slen && j<tlen){
        if(j==-1 || s[i]==t[j]){
            i++;j++;
        }else
            j=next[j];
        if(i==slen)
            return j;
    }
    return 0;
}

int main(){

    //freopen("input.txt","r",stdin);

    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%s",text);
        scanf("%s",s1);
        int len=strlen(s1);
        strcpy(s2,s1+(len+1)/2);    //从一半之后进行寻找
        printf("%s",s1);
        for(int i=0;i<len;i++)      //将s1翻译成明文
            for(int j=0;j<26;j++)
                if(s1[i]==text[j]){
                    s1[i]='a'+j;
                    break;
                }
        int loc=KMP(s2,s1);     //找到s2的最后一个字母在s1中匹配的位置的next[]值,loc同时也是已经翻译过的字母数,所以下面的需要减去loc
        for(int i=loc;i<len-loc;i++)
            printf("%c",s1[i]);
        printf("\n");
    }
    return 0;
}
posted @ 2013-04-24 17:48  Jack Ge  阅读(332)  评论(0编辑  收藏  举报